Installing XBMC on Apple TV2 5.2.1 (thetered) possible?


Anyone know if its possible to install XBMC on the latest IOS (5.2.1 - only thetered). I have jailbreaked my Apple TV2 and it should be ready for XBMC but after following the instructions on the XBMC wiki site (, I guess the reboot at the end destroys my jailbreak? After running the reboot command the ATV2 only blinks and showing the apple logo once in a while. Any suggestions? :)



apt-get install wget

wget -O- | apt-key add -

echo "deb stable main" > /etc/apt/sources.list.d/awkwardtv.list

echo "deb ./" > /etc/apt/sources.list.d/xbmc.list

apt-get update

mkdir -p /Applications/

apt-get install org.xbmc.xbmc-atv2

mkdir -p /Applications/XBMC.frappliance


I used the nitoTV installer on my ATV2 today to install XBMC and several plug-ins for it. I was able to do this from my PC while the ATV2 was still running and sitting at the home screen. The XBMC icon appeared on the screen and I think the machine may have “re-sprung” but it did not restart or have to be powered off, this kept my jailbreak intact. Hope this helps. ~PJ

One more thing I forgot to ask. Did you run the boot tethered command/menu icon from Seas0nPass while having your USB cable plugged into your PC? If so did it still not boot or did it not have the XBMC icon once it did load back to the home menu?

Hi Odiakan, thanks for the fast reply!


Im not sure if I understand your question. I created the ISPW-fle with sesonpass and then ran the therered thing going through all the steps. After that I disconnected my apple tv from the usb and replaced it with the TVs HDMI before the light went off. When the apple tv started up I could see the FireCore logo on the general settings icon. My problem first occurred when I tried to install XBMC with the commands above from my mac using terminal (SSH). After putting in the last command “Reboot” it didn’t start up again and I had to do a new restore of the ATV and a new jailbreak to get it working again. 

What guide did you use when installing the nitoTV?

I found this, and it worked like a charm :slight_smile:

Same issue… no problem jailbreaking or installing everything…  2 issues i had… none of my add-ons where downloading in xbmc… but worse off… when i tried to get out of xbmc it would freeze and i would have to reboot and do the teethering process all over again.

anyone have info on this… i rejail broke but waiting on info before going on xbmc again

I’m experiencing a couple of issues with 5.2.1 tethered jb. When I installed nitoTV, there were no packages listed. When I tried installing xbmc from aTV Flash Black it would give an error.

i Jailbroke my ATV 2 pretty well, and installed XBMC AND NITO pretty well the only problem am having is whenever i reboot my ATV it only stops to the apple Logo, and it doesn’t continue. then i have to do a [Thetered boot again] to get it boot to the main ATV menu,other than that everything stays intact that i installed. a buddy told me to keep it in the power source. and just leave it like that to avoid the [Thetered boot] cycle.

Put your Apple TV 2 to sleep by depressing and holding the “pause” button on your silver remote.  On some older versions, the same thing is accomplished by depressing the large middle silver button.

No reason to leave the unit constantly on which can only shorten it’s life.