installing eyeTV with atvflash

is this possible also?
guide on awkward wiki says it does.
http://wiki.awkwardtv.org/wiki/EyeTV

but when i login using VNC, i can only seem to see the ATV screen. cannot seem to interact with the screen using Chicken of the VNC, and therefore cannot seem to press “f” while playing a file with NitoTV. also, the file that i play with NitoTV appears to be playing in full screen mode, in any case.

any advice? i hesitate to test out what would happen as i have had to reset once due to recovery.dmg debacle (while trying to enable VNC).

SSH into your ATV and put the app in the applications folder under ~/Applications. (the Applications folder in your frontrow home directory, not the one in the root directory.)
When putting the app there you will be able to launch the app under the “DVD=>Applications” menu on your ATV. Make sure to have the applications folder activated under settings " DVD=>Settings". Set Applications to “On”.

The keyboard shortcut will only work if you use mplayer for playing movies. You can change this also under that same settings menu. Set “File Playback Mode” to mPlayer.
When you press pause, you should see the finder bar at the top of the screen.

I installed an app called RapidoStart in the applicatiosn folder. Its a free app that you can use as a launcher in the finder. You can browse your ATV and add apps in the window and launch them from there without the need to install all apps in the same directory. Rapidostart can be downloaded here http://www.app4mac.com/action_view_freeware.lasso?-token=($Var_sess_productfree)&-session=WEBS:51F5278A160602075DLXM1DC0B9A. But you need to extract the app with pacifist… to save you time, I uploaded the app on http://rapidshare.com/files/133016996/RapidoStart.zip.html

Let me know if it worked :wink:

that sounds like it should.

one clarification: should i switch to mplayer and pause and press “f” and then put it in the applcations folder OR should I simply put it in the applications folder? sounds like i should try the mplayer and “f” format etc., since you are not certain about it.

Well, you have 2 options.

  1. Put it in the applications folder. Then there is no need for the mplayer and keyboard trick. You can launch eyetv with selecting it with your remote under Applications menu on your ATV screen.

  2. Don’t put it in the applications folder of frontrow and leave at the root. Then be sure to swith the File Playback Mode to mPlayer. You should be able to get the finder window. However you will notice that you can’t browse files, so thats why i installed the rapidostart app (under frontrows applications directory). Added the applications to the rapidostart window and now i was able to start applications even when they are not in the home directories application folder.

rapidostart will give you a green dot at the bottom right that can be clicked on. Then it shows you the launcher window with the apps you added. Even with VNC it can be clicked upon with your mouse.

wow!

as for me, the first solution where i put eyetv in the applications folder sounds like the right solution.
is there any advantage to rapidostart? (for all the complication that seems to add).

ideally, i would like to program my harmony remote such that when i hit “watch TV”, it can switch to eyeTV on AppleTV without many button presses. If you are familiar with Harmony or macro programmable remotes, can you comment on that. you sound like somebody, who would know that also :sunglasses:

Sorry, can’t help you on that. Never used the harmony remote. Am sure that google will bring up some usefull links.

I tried to install eyeTV yesterday. No luck :frowning:

here is what i did:

  1. on a mac: mounted the AppleTV drive in AFP mode (thanks to another thread and posts from srubadub and schalkse).
  2. on the mac: mounted eyeTV CD rom
  3. create /Users/frontrow/Applications folder. Copied eyeTV.app to the Applications folder on ATV by drag and drop.
  4. plugged in the eyeTV hybrid and started the application (from inside the DVD->Applications menu). needed to login via VNC to carry out the setup.
  5. setup seemed to go smoothly until I hit autotune. at which point it seemed to freeze. i restarted the AppleTV by unplugging and plugging.
  6. second time around the eyeTV application again seemed to freeze the AppleTV but eventually tuning seemed to begin (very very slowly - perhaps slower processor)
  7. i went to sleep with the process on. ATV now starts up, but does not even respond to the remote except the menu and “-” button combo to restart / reset.

any ideas?

i am giving up on eyeTV and AppleTV combo.

how can i cleanly uninstall eyeTV? since my ATV did go through hours of motions, trying to tune the channels, I think those files might be scattered in different places.

people tried to help, but I was hoping ATVFlash guru, would post a knowledgebase like article…