Installer says my appletv hasn't been Jailbroken when it has with seasonpass just prior

I finally had another ago at jailbreaking and it’s worked.

It is definitely the issue with the ipsw file. there is a version that seas0npass that creats a ‘SP’ version as described above. 

Once i directed itunes to find this file, it worked. 

Hope this is the same problem that is affecting everyone else. 

disconecting the power cord worked for me. Thanks!

I just uploaded an update on season pass… now the ATV2 apple comes up on the tv and then disappears… the tv stays black… this is a fail…

that normally means the ATV is waiting to complete the tethered boot stage (the current jailbreak is a tethered one).    This needs to be repeated any time power is removed or the system has a hard reset.

 

Ok Cheers got it all working… Painful having to do it every time you remove power from it dont you think? My partner likes to power everything off at the wall for all electronic equipment so this will be difficult to manage…

 

What about people in areas that suffer constant black outs? 

Having to do the tethered boot after power off is a definite nuisance, but that is one of the unfortunate consequences of a tethered jailbreak.  Untethered ones are more convenient but it is harder to find the exploits necessary to produce them.

I know some people who have installed a small UPS just to protect some equipment against power off issues, and in such a case the ATV is a good candidate to be connected as it can run for ages in sleep/standby mode off a UPS>.  Another possibility is connect the ATV2 to a different wall socket so that it is easier to avoid powering it off in the first place.

I am having a similar problem.  
One day it was working, and the next day I came home from work and it was un-jailbroken.  All of the aTVFlash software was gone.  I have two ATVs and the other one is fine.  When I tried to fix the problem using the latest firmware, it goes through the Tethered SP process, but gives me the Oops … error when trying to install aTVFlash.  Thoughts?

Your appletv may have automatically updated firmware and that’s why it un-jailbroke… turn off automatic updates.

Firecore probably released an updated version of their aTVFlash, firecore won’t let a old version install for compatibility reasons. If you are still under license you can download the latest version free.