Installer says my appletv hasn't been Jailbroken when it has with seasonpass just prior

My installer keeps coming up with the error:

Oops, it looks like your AppleTV has not yet been jailbroken.

Instructions for jailbreaking your AppleTV can be found here.

This just follows a successful jailbreak using the latest untethered season Pass.... any suggestions?

Hi,

I experienced the same problem. Then I disconnected the power cord from the ATV2 and connected it again (cold boot). After this the setup was successfull. Please note to also start aTV Flash (black).pkg again.

Good luck

Robert

Thanks Robert.  In my case it turned out to be becasue Itunes would not update the appletv because of a missing # in my host file.  I fixed this with the terminal

i need help im having the same issue i tryed all the things yall tryed but no luck PLEASE HELP ME

This fixed it for me:

Disable Wifi on your PC or Mac then connect it and ATV to your network with ethernet cables. ATVFlash now transfers the files with no problem’s.

 

 

Hey thanks dude. After multiple failed attempts to jailbreak and install ATV Flash, finally your answer has given me the real working solution. Cheers 8)

 

can someone explain this a littel further please Ive been stuck for two days since buying atv2 and this software.

 

so disable the airport on my mac to prevent wifi (check mark that)then what hook up a ethernet cord from my mac to the atv2 and

run the installer??? (check mark that)cause if so I get the same dialouge coming up again and again highly annoyed right now :frowning:

any feedback would be greatly appreciated is my hook up procure wrong someone please let me know if this is wrong how i have the
ethernet cable for I am ready to use this software days ago thanks in advanced!

I went through three attempts at jailbreaking. I finally realized that I was not letting itunes restore the atv2 with the newly created restore file. Once I pointed itunes at the correct file, everything was fine. User error on my part.

Thanks guys for the tips. However I think that my problems is indeed iTunes updating the ATV with the incorrect restore file. How and where do i direct iTunes to the correct restore file?

Thanks,

So I’m having the same issue as well. 

The install process with seas0npass seemed to work fine. 

But atv flash black still tells me its not jailbroken. 

I’m really not sure how to hook up the ethernet as people have suggested. 
Is there a simple way for the mac to be hooked up to the apple TV to install atv flash black?  

really frustrated… 

For those having trouble please open a support ticket and send in the ‘FC_Installer.log’ file found in your Documents folder. This will help us troubleshoot what’s going on.

I have now got everything working:

When I allowed iTune to restore the AppleTV it was simply restoring it with the default file that iTunes looks for. To direct iTunes to the new file that you have created with Seasonpass, you simply hold the shift key when you cilck on the restore button in iTunes. After a few moments you will have a dialogue box asking you where the location of the restore file is. You will find it newly added in your documents folder. Click on this file and it should work perfectly when you then connect the AppleTV up to the Tv and load up the software using ATV Flash.

I’m having the same issue.  I’ve tried wired/wireless connections, rebooting, and directed itunes to the correct .ipsw file.  Still no luck.

Can you make an SSH connection to the ATV2?   If you cannot then it almost certainly means you did not restore the correct .ipsw file.  If you can then instructions are available on how you can use the SSH connection to install the FireCore software when the installer fails to work correctly.  The exact detail of these instructions will differ slightly for OSX and Windows although the basic steps are the same.

I cannot make an SSH connection.  What is the correct .ipsw file name?  I’m on a mac if that helps.
I found one called “AppleTV2,1_4.3_8F455_Restore.ipsw” in a newly created folder in …/Documents/Tether, but I wonder if that’s a factory restore file now.

Also for more info, when seas0npass is done running, it says the restore script was successful, but I get a window popup looking for a null folder.  Is this normal?

[[wysiwyg_imageupload:96:]]

I am on Windows, but I found 2 .ipsw files relating to SeasonPass.  One was the “AppleTV2,1_4.3_8F455_Restore.ipsw” file you mentioned - and this is the standard Apple firmware downloaded by SeasonPass.   SeasonPass also created a file called “AppleTV2,1_4.3_8F455_SP_Restore.ipsw” (note the _SP added to the name) and this was the jailbroken firmware that had to be restored.   You might want to see if you have that file anywhere on your system?   Alternatively maybe a Mac user can chime in with the correct name and/or location on a Mac system if it is different.

Yes, this is my problem.  Seasonpass is not creating another .ipsw file with SP in the name.  A search on my machine didn’t bring up any other .ipsw files other than the one I mentioned.  Not sure what to do now about it, I don’t have any security or firewall systems on.  Thanks for the help so far and if there’s a mac user out there that can provide additional details that’d be great.  It’s frustrating but at least we know now what’s going wrong.

My problem is resolved.  Thank you to users on this forum as well as firecore support.

For reference to others out there, upgrading to OSX Lion and reinstalling Seas0nPass solved the problem for me (not sure which one did it, but I did both).  For mac users, the AppleTV2,1_4.3_8F455_SP_Restore.ipsw file created by Seas0nPass is located here: ~/Library/Application Support/Seas0nPass/Firmware

Previously, my issues stemmed from Seas0nPass not creating an .ipsw file in that location.  Once that file was created, everything else went smoothly.

Now it’s time for me to finally enjoy using this software!

if the ipsw file is located in the ~library/application support/seas0npass folder…

does it matter that i’ve got a SSD partition and a HD home folder?
maybe that’s the problem?