installation failed (newbie)

I am having trouble installing aTV (black). I get installation failed.  “Oops, it looks like your Apple TV is not accessible, or the connection was blocked by your firewall.  Please check your Apple TV and firewall settings and try again.”

I have turned off the firewall on my computer and no luck.  My modem/router is a 2WIRE 3800HGV B Gateway.

Not sure what to look for on the Apple TV 2 - if there is something that I need to adjust?

i can see ATV at my computers, apple devices, etc.  Installation can see the ATV2.

Jailbreaking was successful as was the tethered start up of my ATV2.  Any help would be much appreciated.

Is there a way to do this directly instead of over my network?

Hi. I’m by no means an expert as I’ve only been jbing a short time, but with the amount I’ve read, I can possibly help you solve this. I use cyberduck to ssh the apple tv and it used to be so hard to connect…but I changed the following and it works 100% of the time now. 

For me, I had all sorts of problems installing updates or connecting to the apple tv. What I’ve found is that usually switching your router off and on gives a short term solution. It seems that major connection problems installing atv black is similar to using mirroring etc…the connection soon drops or doesn’t even start. If you can, go into your router settings and make sure your router security is set to WPA2. This is more secure, but a lot of routers have by default a mixed mode of wpa/wpa2. Since switching to wpa2, I’ve never had any problems connecting to the atv over wifi since. Maybe also switch your firewall off whilst doing so, and maybe do a hard reset on the ATV before trying again. This’ll probably be lambasted as being wrong…but you never know! Good luck!


Checklist. Switch everything off and on. Change router security to forced wpa2. Restart everything again. Retry the atvblack. 


Hey you’ve gotten as far as the jailbreak. This is the easy part!



I re-jailbroke my ATV2 and now i have successfully loaded in xbmc, etc.  Thank you.