Installation Failed! installing media player in aTV Flash (Black) on tethered JB 4.4.4

I’m trying to install the media player (the one thing I really want).   I was able to install aTV Flash (Black) successfully.  (BTW, does iTunes need to be running to do that, because that’s what I had to do to get the aTV Flash install to work).  I am getting the following in the log:

Installation Failed!

E: Broken packages


Building dependency tree… 

(etc, etc, etc…)

The following packages have unmet dependencies: Depends: com.firecore.libafpclient(>=1.2-18) but it is not going to be installed

Depends: org.xmbc.xbmc-seatbeltunlock(>=1.0-4)


There’s no option to install xmbc from the Manage Extras menu, and as I understand it, that is not working, right now, anyway (

I’ve sent the diagnostic information via the settings menu.


What Do I need to do to get media player working?



I am on 4.4.4 as well and have the same problem with, Media player and nitoTV. Do help us sort this out, thanks

FYI, I was able to resolve this myself after some digging.  I found the following post:, and this: link on xmbc nightly builds.

I tried to follow the apt-get commands, but was having little luck.  First because I mistakenly typed app-get :[, but then because there was an existing apt-get update process running (ps -ef to show processes).  After killing that process, I was able to get the apt-get update to work.  I decided to also install the nightly build of xbmc.   Both xbmc and media player appear to be working.



Thanks for the tip. However I moved back to 4.4.3 and now i have every thing working. The only thing I lose is mirroring. As well wait for them to resolve everything before I move to 4.4.4.


Thanks this worked for me

there is still the same error, any news on when this will be fixed?

Yes, please, come on… just paid 30 usd and then two of the most important features (for me) are not working :frowning:

did you guys upgrade to the untethered season pass for 4.4.4? 

I just upgraded my ATV2 and Media Player will not install.  XMBC will not install too.


Couch Surfer Pro and Remote HD installed fine, but Media Player keeps saying “Installation Failed”


When will this be fixed???


I unplugged my atv2 from power, waited 10 secs, plugged back in and tried again and it worked!!


This worked for me as well - thanks for the tip!

Also worked for me, thanks!


This worked for me as well. Except - I had the same problem with the new 4.4.4 untethered install - and doing what you suggested seems to have worked. Thanks!

The install is not obvious however - what the docs imply is that a number of apps will just appear - you have to enter manage and actually install them for them to appear. So… maybe an update to the install docs would help? Either way - I’m happily fooling around with my ATV2!



Worked for me too, although when it rebooted it just went to a blank screen so I did a reboot using the remote (pressing and holding the Menu and Play/Pause buttons together) and when it rebooted I selected Install Media Player and it installed fine!

this trick just helped me when installing xbmc on untethered  v5, thank you