Installation Failed! from Maintenance Menu


I am keep getting jailbroken Apple TV2 from Maintenance Menu that Installation Failed!

Retry Installation

View Log

When I select View Log then I get following error…

E: Unmet dependencies. Try ‘apt-get -f install’ with no packages.


I did try apt-get -f install using ssh and reboot several times but no luck. Please if anyone has any good solution then post.

Thanks in advance.




If you jailbroke your apple tv using other tools other than Seas0nPass, you may want to rejailbreak yours with Seas0nPass. At least, mine problem was solved after re-jailbreak with Seas0nPass.





Hi Thanks for you comment but its very risky to re-jailbreak right now. Its already jailbroken and I do have access to SSH with alpine password. I can also get successful access with Cyberduck so there is not necessary to re-jailbreak.

If I get apt-get -f install error that means I must follow up some new command and get troubleshoot from there. If anyone has this same error then post what else could be done.



What tool did you use to do the jailbreak?   Depending on the tool the list of dependencies missing might be different.  There was a post recently (cannot find it off-hand) about how to install the dependencies required by the FireCore apps if you used something like Sn0wbreeze.

I always use Seas0npass and Black Flash 2.2 to install XBMC and Couch Surfer Pro


I’m having the same problem and used seasonpass and the firecore for ATV2.

can’t install xmbc


I’m having the same problem and used seasonpass and the firecore for ATV2.

can’t install xmbc


A lot of Apple TV2s on the market that are jailbroken are stuffed to the gunwales with crud and the reason you can’t flash it with ATV can be that the NAND flash chip is just plain full.   Navi-X in particular can use up a whole lot of space.

I suggest using SSH to remove the XBMC directory, install fusion, download and install XBMCHUB Wizard.  Start afresh.

The Catch-22 is that most folk won’t be able to install XBMC and thus fusion, without being able to install ATVFlash…

My post about 4.1.1 jailbraking gives the apt get routine to install XBMC from the command line…