Installation 2.1 fails

Trying to install the 2.1 version from the maintenance menu but it fails without any entry in the log. Hitting “retry” gets me “installing (null)” but with no success at all and I stop the retry after a couple of minutes (10). Again there is no entry in the log.
My network is working fine, checked via ATV.

Any one else having installation problems on v 2.1?

i also have problem with the 2.1

"Lo sentimos, el instalador no ha podido instalar Mantenimiento (Error 9.100.). ¡Ayuda!"

I get the same problem when trying to update through the “Maintenance update” option. I get the spinner then the report that ‘Installation failed’ if I click ‘retry’ it just repeats the procedure if i click ‘View Log’ the log is blank
Anyone got any ideas??


Looks like I’ve bricked my ATV with this fine update.
Won’t even restart.
Won’t boot up.

exactly the same at my device…it hangs after reboot and it never shows anything except the circle is turning…


I can reboot…Apple Logo appears…and after that nothing…only the the rotating circle in the middle of the screen…


Needs to make a factory reset?


Please assist


As far as i see through SSH:


apt-get update


fails on nito repository.

So maintenance,is located there… so cannot update.

Problem of Nito repository is the PGP overdate key… someone could report it.

Anyways, i guess FIRECORE must provide us support… i just bought and renew the Life Update… and got this error… my ATV is now base without ATV Flash…

So, it looks like quite a few different issues going on here. I’ll try and address a number of the most frequent ones people run into.

  1. If you're seeing any kind of errors when attempting to update via the Maintenance menu on the Apple TV, you may try re-running the aTV Flash (black) installer from a Mac or PC. Usually this will clear things up, but if not then please open a support ticket and send in a diagnostic report as described here.
  2. If you're seeing an error when running the installer on a Mac or PC, then it's best to send in the 'FC_Installer.log' file (found in your Documents folder) as that will help us track down what's going on.
  3. If you're getting a black screen, or the Apple TV won't start up after installing aTV Flash (black) this most likely means you're running a very old Apple TV version and need to update. aTV Flash (black) 2.0 and later will require Apple TV version 4.4 or later. Updating the Apple TV is as simple as running the latest version of Seas0nPass on your Apple TV.
  4. If you're seeing errors when trying to update/install via SSH, then simply stop using SSH.  ;) But seriously, for our sanity it's best to just run the installer and send in the log (as described in #2 above) if you're having any trouble.

Hope this helps. :)


I just solved my own problem and it was al due to that my memory was full in the ATV. I found that out while I was trying to do a full re installation and was prompted with the error code 2.2. After some searching in the forum I found out that clearing the cache could free up some memory. That worked for me and the installation worked fine now.

read more about clearing cache here: