install Maintenance (Error 4.1).

Has anyone seen the error  “Sorry, the installer could not install Maintenance (Error 4.1). Help!”

I’m using the latest AppleTV update along with the newest Jailbreak andATV Flash. I have tried wifi, ethernet plugin as well as the Airplay trick referenced for other errors.

I’ve opened a support ticket but have not heard back since it was opened on the weekend.



Post the FC_installer_log.txt that is located in the Documents folder.

Hi Guys,


The post above fits completely my problem.

Apple TV2 iOS 5.1 with tethered Seas0nPass. XBMC is already running. I installed it using the terminal via SSH connection.


I tried wifi/LAN and the “AirPlay-Trick” as well.


I’d be really glad if someone could help me.


Here is the only error I could find within my log file: (complete log file is attached)

2012-04-04 20:52:24 -[AppleTVInstallerUploadPluginPane sshUploadServiceFailed:] service <SshUploadService: 0x7fda928633e0> result 4 executionError 1



Thanks in advance to everybody how is trying to help.




I tried to execute the last readable command out of the log file directly in the shell connected to Apple TV.



dpkg -i /User/tmp/com.firecore.sources_1.0.deb

(Reading database … 3281 files and directories currently installed.)

Unpacking com.firecore.sources (from …/com.firecore.sources_1.0.deb) …

dpkg: error processing /User/tmp/com.firecore.sources_1.0.deb (–install):

unable to create `./etc/apt/sources.list.d/firecore.list’: Read-only file system

Errors were encountered while processing:



 Read-only file system?

Does that help?


Log Attached.



Hmmm - ‘Read-only filesystem’ definitely doesn’t sound normal.

Was Seas0nPass used for the jailbreak? Mac or PC version?

Yes it was seas0npass for Mac.
Can I change it through ssh or should I do a factory restore and rejailbreak?

Same here. I used the latest version of Seas0nPass on my Mac.



Because of my read only problem I had a look into my fstab but it seems to be ok. What do you think?


/dev/disk0s1s1 / hfs rw 0 1

/dev/disk0s1s2 /private/var hfs rw 0 2

fstab (END) 


Thanks in Advance


*edit #2

I could solve the problem. Damn, I’m happy.


Resolution: Just make the file system read write:

mount -o rw -t hfs /dev/disk0s1s1 /

mount -o rw -t hfs /dev/disk0s1s1 / did the trick for me as well.


Any negative consequences to doing this or is this the way the file system was supposed to be after the jailbreak?