Install keeps failing. Can you help?

I am trying to install the new aTV Flash (black) through my PC and everything works until it tries to transfer the files and then it fails saying:


Oops, it looks like your apple tv is not accessible or the connection was blocked by your firewall. Please check your apple tv and firewall settings and try again.

What am I checking for? I took my firewall's down completely and am still having no luck. Can someone please help?

How are the PC and ATV2 connected to your home network?   Many routers block two WiFi devices from talking to each other.  If you know the IP address of the ATV2 it might be worth seeing if you can ‘ping’ the ATV from the PC is a Command window.


Thank you. I will try that. They are both connected on the same router. Do you have directions on how to ping? I am a very novice user. 

I had no luck with the pinging. Any other suggestions?

Do you mean that the ping is failing, or that you have not worked out how to do it?

If it is failing then it suggests you ahve a network issue.  I would look closely at the settings on your router to see if there are any that relate to devices on the same WiFi network talking to each other.

Another possibility is to see of you can do AirPlay to your ATV, or if the ATV can play items from iTunes.   In fact in the past some users reported success trying to install if at the same time they had something using AirPlay.

Thank you again for your help. The ping worked fine. 4 packets sent and 4 received. I will check the router setting and see what I can find.

AirPlay works fine and I tried running the program while playing a song from iTunes and still had no luck. :frowning:

Thank you again for all of your help. I re did everything and was able to get it hooked up. All set.