Install failed

Trying to install ATV Flash 4.1 on my 2nd Apple TV, which has the latest ATV OS (3.0.2?). Patchstick creation is successful, and it unmounts and tells me it is ready to use. When I plug it into the Apple TV, the Fire Core logo comes up and it appears to be detecting the flash drive. Then the screen goes black for 2 minutes and comes back on with a progress bar and says “loading.” After about 10 seconds it says “Installation failed, please try another USB drive” or something of that sort.

I’ve used this exact USB drive before to install ATV Flash 3.6.3 on my original Apple TV. That worked fine and I’ve never had any problems. I’ve never updated the software on that box because I’ve been completely content with how it functions. I’ve tried another USB drive for this 4.1 install and it does the same thing. The last thing I can think to try is zeroing out the data on the flash drive, but I can’t imagine that will help anything.

I tried installing ATV Flash 3.6.3 right when I got this Apple TV out of the box. It had 2.4 installed so I figured it would function exactly as my other Apple TV does. It was giving me errors during the installation, so I figured I may as well update to 3.0.2 and try to install the latest ATV Flash. No luck anywhere. Help?

Part of the errors I am getting with older versions of ATV Flash, as well as with the patchstick from atvusb_creator are as follows:

Initializing USB Mass Storage driver…
usb 1-1: new high speed USB device using ehci_hcd and address 2
usb 1-1: device descriptor read/64, error -110
usb 1-1: device descriptor read/64, error -110
usb 1-1: new high speed USB device using ehci_hcd and address 3
usb 1-1: device descriptor read/64, error -110
usb 1-1: device descriptor read/64, error -110
usb 1-1: new high speed USB device using ehci_hcd and address 4
usb 1-1: device not accepting address 4, error -110
usb 1-1: new high speed USB device using ehci_hcd and address 5
usb 1-1: device not accepting address 5, error -110
usb 2-2: new low speed USB device using uhci_hcd and address 2
usb 2-2: configuration #1 chosen from 1 choice
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.

oot=patchstick – searching for patchstick.sh
oot=patchstick failed - starting telnetd

I find it hard to believe that there is a problem with my USB flash drive, considering I have successfully installed ATV Flash with it before. Any ideas?

My Apple TV no longer seems to recognize an aTV Flash USB key when starting up. I loaded 4.1 onto a patchstick and started it up and it just goes to the Apple logo. This is really frustrating. Is it possible that the USB port on the Apple TV is now broken? Should I just sell the damn thing and buy another one and hope I have better luck? What could possibly be the difference between my two Apple TVs that would allow one of them to install the software, and the other one won’t?

Have you tried restoring the one that gives you issues before running aTVFlash? Maybe it is in some funky state after your earlier attempts, and just needs a restore.

Yeah I thought maybe that might be an issue too, since I bought it used I thought maybe the previous owner had it hacked before me. But he restored it to factory (2.3) settings before selling it. I’ve restored it another 2 times since then, but that hasn’t helped. I read an older comment from a moderator about checking in /Volumes on my Mac and deleting the patchstick-root folder. I did that and ran aTV Flash again and now the Apple TV recognizes the USB drive again and brings up the Fire Core logo, but it says to try a different flash drive. So far I have tried Sandisk Cruzer (1GB and 2GB) with U3 removed, and a Lexar Firefly drive (which is the one I successfully installed aTV Flash 3.6 with).

Tried an SD card today with card reader, still no luck.

Has the internal drive of your 2nd AppleTV been upgraded or replaced?

Not that I know of, seems to be the stock 40gb

Bringing this back from the dead for one last post. For the last few months I have just been streaming from iTunes to this Apple TV since I never got aTV Flash to install correctly. Finally got sick of that and found a good deal on a used 160gb and picked it up. aTV Flash installed first try, quick and easy. All the features that I love about my other Apple TV with aTV Flash (FTP!) work perfectly. If anyone has any insight into what could cause a (seemingly) stock Apple TV to refuse an installation I would be curious to hear the answer!

To add to this issue, I recently bought a refurb 40 GB atv with 3.02 stock and tried with my friend almost 20 different usb stick with some listed in the compatibility list, like Memorex datatraveler 1GB or Danelec 1GB, generic usb, multiple SD cards using reader… followed all the instruction, removed U3 where necesssary, formatted and zeroed drives and it failed to boot to the USB… Never had the chance to see the atv flash logo. Even tried other free methods with no go!
To add to the frustration, some of the USB stick I created work on my friend 2009 40GB ATV while on mine it doesn’t! Apple has apparently modified something on new ATV with 3.02 stock and I think that actually we do not have the hack to boot from USB or the USB boot has been disabled.

Could some confirm that!!!

I will respond my self to the issue… the ATV had probably a hardware problem or any boot software corruption making it not booting on any usb device… Changed the ATV under warranty and boom first stick it worked and installed correctlty…

So for those having problem booting with usb stick that are known to work, it’s probably an ATV problem with hardware or boot software… it was the case for me at least!

Same problem! Brand new ATV. Try to install with a memorex traveldrive 2GB but not recognize by ATV. Maybe the new ATV cant boot from a usb. How can we verify this without returning the ATV to apple store… :expressionless:

I was able to install boxee on my new ATV.
See this site: http://www.ievolution.ca/how-to/how-to-install-boxee-on-apple-tv/
The usb patchstick just works fine using a memorex travel drive 2gb. Why then ATV flash cannot be install on my ATV??? So I guess the problem is not my ATV but the ATVflash install software. Please repare your 50$ software that cannot be installed. So much buyer disapointed… :x

Hmm, did you follow the install guide here: http://wiki.atvflash.com/index.php?title=Install

Yes the patch stick creation process without problem report but my ATV does not boot from it memorex travel drive 2GB. When I use the same drive to boot with atvusb-creator it works and install boxee… I need couchsurfer, this is why a bought ATV flash. Is it possible to install ATV flash using SHH script?

I am too having this very same problem…

I originally bought 3 appletvs when they first were released, with grand plans of using them…they sat untouched in a box for 3 years…I finally got around to hooking one up, tried a flash drive…no luck, switched to another…boom, atvflash installed first try…been using that one ever since…of course, i’ve ran into issues on that one too…

Today, I went to hook up my 2nd unit in my sounds room…tired of them destroying DVDs. Grabbed the same usb flash drive…ATVflash logo pops up, says starting install…then it says Install Failed use another USB drive…

Very weird this same USB drive installed perfect on the other unit, but not this one. These are literally from the SAME order…the serial numbers are only a few digits off…I guess I gotta find the 3rd unit in the garage and see if its got the same problem…

So, what is going on? What did I pay $50 for? Counting the issues I am having with the other, I am about to ask for a refund on this software and just use the AppleTV stock…I am spending more time getting stuff to work and such than it would be to just convert movies to mp4 and play em on a stock appletv…

Later EddieO

Here is my similiar story: I have owned an AppleTV and flashed if for years without issue. I just bought 2 more directly from Apple. One flashed fine. The other says it flashed successfully, but after a reboot, I see nothing but the stock AppleTV interface. No Nito, XBMC, Boxee, etc.

Any ideas?