Infuse won't connect to imac via SMB

Dear James
This is a continuation of a closed topic.
I cannot connect to my imac1 via SMB.
I am able to connect from my iphone or my mac book via smb://eilamgross-s-imac1.local and it works without any problem. But infuse 6 pro refuses to connect.
I downloaded Wireshark as you suggested.
NOt sure what do you want exactly.
Here is a screen capture:

I will appreciate if you answer ASAP and tell me how can I further help you…
here is another screen capture:

Could you provide a screen shot of the Infuse settings on your ATV of this page?

And also a screen cap from your iMac from the System Preferences > Sharing page like this one except on your screen cap could you highlight the “File Sharing” in the left hand column.

and i can connect via my iPhone (SMB) with the same user name and password:

Can you use Infuse on your iPhone without a problem?

To my surprise the answer is NO

Thanks for bearing with me on this, trying to figure out what’s going on since you’re having a problem that I haven’t seen before.

Could you also do a screen pic of the the available shares in the Infuse settings?

There is only one:
A mac book pro
and it works just fine
but i use it for work and its not my personal “movies” computer

How are the Mac Book, iMac, and the ATV Connected to the LAN? If WiFi, are all on the same band? IE 2.4Ghz or 5Ghz

I apologize but I can’t read the language on your screen cap, what is the one above the Mac Book Pro? Is that a saved share?

Thank you for sticking up upon my problem…

  1. Yes, it says “saved shares”
  2. It was all connected through 5G with the iMac connected also via cable… However… following your question I changed all to 2.4G and disconnected the cable, it did not help. Moreover, the MBP stayed with 5G while the AppleTV was 2.4G and it all still worked just fine with the MBP.
    (the 2.4G and 5G all come from the same router)
    Very frustrating

This is very curious. Could you tell me the year and model of your imac and what OS?

It’s almost like it’s not broadcasting on the network that it’s a server for files.

I’ll dig some more and if you can get me the above info it’d help.

Thanks! Is there anything below the “Eilam’s MacBook Pro” on that screen?

Please see the movie I uploaded in dropbox:

As for my Mac answer follows

My Mac (now Big Sur but the problem started with Catalina)

Can you try adding your iMac using its IP address instead of the .local in the “Address” field when adding a share?

If that enables you to connect via Infuse I think we might be facing the same issue. See: Infuse can't connect to SMB shares anymore - #8 by naurtak

For me, using the IP address makes Infuse able to connect to the SMB share. If I use the .local address it only works rarely under circumstances I am not able to reproduce.

Sorry for my ignorance
My ip address is how do I connect via IP?
Where do I write and what?

In the “Add Files” menu under “Available Shares” (or something) there should be a “Other” button where you can add shares manually.

It looks like this menu but you can edit the field where it says “eilamgross-s-imac1.local”

There, replace “eilamgross-s-imac1.local” with the local IP address of your iMac. Not sure if 10.xx… is your internet or local IP. On your Mac you can open the Network page in your system settings and it will tell you the local IP of your Mac.

but strangely enough I cannot connect via ip neither from the phone or the MBP
only via the local eilamgross-s-imac1.local

Strange. But thank you for checking.

These 3 screen captures (when trying to connect to the imac1 from my MBP) make my point:

Perhaps it gives you a n handle to the problem…

I’m setting up a big sur iMac to try a few things for this but in the meantime, just a wild shot in the dark, could you try changing the address from “eilamgross-s-imac1.local” to “eilamgross-s-imac1.home”? I had this affect network connections before and for some reason on Mac sometimes changing the word local to home made things work.