Infuse will only cast after playing on iPad first

Hi I am a relatively new Infuse user, having first encountered Infuse 4 free, I realised it’s potential to play my wife’s DVD collection. I ran some tests using handbrake to save a profile compatible with Infuse and proceeded to rip each DVD named in accordance with IMDB naming convention. Everything was working casting movies from the WD Mycloud to Google Chromecast via my iPad so I made the investment to upgrade to Infuse Pro 5. Many months later I finished ripping the DVD library and replaced the WD Mycloud with a WD Mybook Duo as the Mycloud died. I can play the DVDs instantly on the iPad, however, I am unable to cast them to the chromecast. Or so I thought. After playing around with it I found out if I play it on the iPad first for a few seconds and then switch to the chromecast it works. I just don’t understand why it won’t cast to the chromecast in the first instance. Any assistance would be appreciated.

The Chromecast option is only available while a video is playing. However, Chromecast will remain enabled if you are playing multiple videos in a row.

EG

  1. Start playing video 1
  2. Enable Google Cast
  3. Finish video 1 & start video 2
  4. Google Cast is enabled automatically

You might also look at using Infuse 7, as this has quite a few improvements compared to Infuse 5. You can also get a free year of Pro when upgrading.

Hi James,

Thank you for your quick reply. I get what your saying but that is not how my system is behaving.

1 Start playing Video 1. TV turns on, iPad waiting circle spins until Infuse times out, TV has a black screen.
2 Close Video 1 and start playing Video 2. First few “frames” are viewed on the TV then video stops playing.
3 Close Video 2 and start playing Video 3. First few “frames” are viewed on the TV then video stops playing.
4 At this point Infuse refused to switch to iPad from casting, normally it would just switch so possibly just an isolated issue.
5 Shut down Infuse and restart.
6 Start playing Video 1 on iPad, change to casting and Video 1 plays on TV.
7 Close Video 1 and start playing Video 2. A few more “frames” are viewed on the TV then video stops playing.
8 Switch to iPad and Video 2 starts playing on iPad, then switch back to casting and Video 2 plays normally as expected.

I haven’t seen that casting a video first is the issue I am having, even though the expectation from a users perspective is you select a movie and cast it wherever and it plays. Playing a video to connect then playing a different video to make it work is not how casting works on any other platform I use. My issue is I can only cast to my TV by playing the movie on my iPad first.

Regards,
Wolf

Have you tried this in Infuse 7?

No can I do it on trial version first?

You can receive a free year of Pro when upgrading to v7.

Yeah I was trying to avoid a subscription model and I own 5 outright. Just not working like it once did is disappointing.

I understand, but Infuse 5 hasn’t been updated since 2019, so it’s pretty old at this point.

There have been quite a few iOS and Google Cast updates during that time. Not to mention improvements in Infuse itself.

Hi James,

So I upgraded to Infuse 7 Pro and the same issue persists, only now I have an error when switching from the iPad to casting which forces me to close out of the movie and go back in.
The idea was for this to replace getting a DVD out of the cover and inserting into the DVD Player and pressing play. Now I have to try explain to the family they select the movie, start playing to the iPad first, wait a minute, switch to casting, it will error so close out of the movie, then go back into the movie, play to the iPad, then switch back to casting and it should work.
Shouldn’t I be able to tell them “Select a movie and press play”? After all this was my reason for investing in Infuse.

Regards,
Wolf