Infuse + Synology DS214play + Media Server


I’d like to confirm if the only way Infuse access the Synology NAS is through the SMB protocol: In the promotional image I saw it’s possible to access DiskStations with the UPnP protocol, however, that one is not an option for my NAS, and the only way to access is using SMB one.


You can try to connect via WebDav like i have do and working 100% without any issue.

I’m not user-friendly with all of this, howver when I installes Infuse (my 1st program on ATV4) and tried to discover my Synology DS210J I could only choose: FTP and SMB…
I tried both…but could not get to load any content from it!
Suddenly…and I’ve not changed anything…the UPnP appeared, I could connect, and watch the contect, even if sometimes I do have a an error “Coul not load the content”!
Do you know if connecting via SMB or FTP will solve the issue? If yes, do you knwo how I can proceed? and by the way…are we sure there is no issues/bug behing the issues on connecting via UPnP?

Did you activate Windows file sharing the DSM interface? SMB is preferred over DNLA as there are some bugs in the 4.0 and the metadata fetching.

thanks for the help, but unfortunately it doesn’t work.
I’e checked on the NAS and the file share is activated, I’ve additionally set-up a specific workgroup name (DISKSTATION).
Than I tried to connect the ATV4 and Infuse to it by using SB + DISKSTATION as workgroup name + user name and password as the one I use to connect to SYNOLogY NAS.
Infuse try to connect forever…and no possibility to see any folder or content