Infuse suddenly startet loading endless on some movies

I have been using Infuse for a few years now, and it has been working like a charm. At least until today. I got a new router from my Internet supplier, and I have been setting it up like the old one.

Strange thing is, that Infuse suddenly startet loading endless on some movies in my library now. Others are working fine without problems. All movies are same format and about same filesize, but some certain movies are loading for every 10 seconds. Others are not.

What is happening, and how can I make it just like before?

Are you connecting via wifi or Ethernet? If wifi it sounds like the new router isn’t as solid as the one you replaced. You may have to play with how its oriented.

My ATV is connected through Wifi. But this theory does not explain why 10-15 movies are working fine, and one or two is not. They are same file size and format.

There is a difference somewhere if it’s the same files that play error free and the same ones that have issues. As a test, can you connect via Ethernet and see if you have the same results?

No, unfortunately not. My Apple TV is very far from my router

Well since the change came with the router change I’d say to start with seeing if the new one has settings for streaming priorities and maybe adjusting the position of the router antennas. Where are your files stored? NAS or drive attached to your router?

Files are stored on a Seagate Personal Cloud NAS. But I really don’t think it’s got something to do with the router og the signal to the router. I have tried to setup Infuse with UPnP, instead of SMB, and the movies, which are loading on SMB, is not loading on UPnP. So I’m pretty sure it’s not about the signal

Maybe someone else has an idea. I don’t see how it could be an infuse issue when the only change was the router. Changing to DLNA or UPnP could add multiple additional issues so make sure you can get back to square one.

Good luck!

Any idea of which changes in the routers configuration that could be causing this?

Brand and model of the router would help as well as the specifics of the files that are causing issues.

I guess I have fixed the problem. I changed the SMB setup from “Auto” to “Legacy”, and so far it’s working as normal.


Hmm… it turns out: it’s actually not working at all anyway. Now its loading on all most everything. Any suggestions?

And again , it’s difficult if not impossible to help further without you first providing the information asked for above.

Oh yes, sorry:
Brand: Sagemcom Pack Fast 3890 W
Files: MKV files H264. About 40 GB size

I can’t locate the users manual in English so I can’t help with the settings. Sorry.

I will say that often, WiFi equipment furnished by the cable companies is less than optimal. You may get far better results by purchasing your own name brand WiFi router and getting one that will serve you better.

If you would find a Ethernet cable long enough to just temporarily connect your ATV for a test and see if you still get the buffering when on a hardwired connection would help you narrow down the problem.

I’m 95% sure the issue lies in the new router, either it’s not as good of a wireless radio/antenna set or it’s in some of the settings that are causing the problem.

I guess you’re the router being the problem. I just don’t think it’s the signal, since I have no problems with any other products; ATV streaming from streaming services, PS4 playing online or anything else. When I’m running PS4 online it’s running much better and more stable then the old router.
I guess it’s gonna be something about the configuration. My other theory is my Seagate PersonalCloud, which has begun running more unstable lately.

What I would do is the following:

  • Have Infuse back to using SMB automatically
  • Reboot in the order: Router, NAS, Apple TV
  • Test again

Still I concord that the issue should be with the WiFi. Just for testing I would try moving the ATV (and a small television) near the router. If possible. Then I’d test if it works fine via WiFi and also wired. Also you didn’t specify if the NAS is wired or connected via WiFi (unless I missed it). If both NAS and ATV are connected wirelessly you’re looking for troubles with files of that size. Also I’d make sure both are using the 5GHz network (which must be available and it is better if you create two different access points for the 2,4Ghz and 5Ghz signals).

Actually, if you still have the old router, you could try to chain the two routers via ethernet and use the WiFi from the old router (since it worked). It would require a bit of configuration for the old router.

Or, as another option, if most devices are in the same room of the ATV, you may consider the option to buy a couple of Powerline Adapters (PLA - they create a LAN via the electrical wires) plus a 1Gbps ethernet switch, as I did. This is the scheme:

Internet <-> Router ← Ethernet → PLA 1 ← electrical grid → PLA2 ← Ethernet → 1Gbps Switch < Ethernet → All devices

It’s better if the NAS and ATV are both connected to the switch. Actually it’s nearly mandatory since the PLA aren’t very fast. Mine reach 200Mbps. But my connection ATV <-> NAS since is via the switch is 1Gbps.

PS: I can’t find any Sagemcom Pack Fast 3890 W. Only 3890 V2 and 3890 V3

I will try to wire it up - when I find myself a very long cable :slight_smile:

My NAS is wired, so there shouldn’t be so much changing around that.

I still got my old router, and maybe I should just set it up once again, just to see if it works again. Then I can narrow the fails to the new router.

Signal in the new router should be better though, it’s a couple of years newer.

It is the Fast 3890 V2

Are you saying each movie is 40GB each??? Those are huge movies, I’m guessing direct Blu-ray rips. For files that size, you would need a roughly sustained 6 MB/s file read speed to your NAS. That’s about a 48mbps connection. Wireless N can get a bit iffy at those connection rates, unless you’re very close to the router. Even SiliconDust, the makers of the HDhomerun box, say they recommend only using wireless AC to properly sustain over a 20mbps.

Apps like netflix, youtube and playstation will be fine on this router since gaming uses <10KB/s and netflix is usually about 5-6mbps for 1080p. You need much less signal strength for those types of services.

If you have a laptop, I would bring it next to the AppleTV and try to copy a file from the NAS to your laptop. If it can’t sustain a 6MB/s file transfer, then your problem is definitely the wifi. You’re for sure probably on wireless N a that distance, and you’re probably on the fringe of the signal quality. Transceiver Wattage is the same as your old router because it’s regulated by the government, so it all boils down to antenna design since wireless N has been out for a long time. Your new router doesn’t appear to have any external antennas and could have a worse antenna design.