Infuse "Stuck" on "Use Embedded Metadata"

First, thanks for a great program! I live in an desert RV park with slow, intermittent wifi, and streaming services to my ATV buffer too much. Rain and wind will knock the wifi out completely all too often.

Getting a tiny router and setting up a local network to stream Infuse content from my Macbook to my ATV has worked rather flawlessly! No buffering!
Being able to use the ATV remote and not having to use an HDMI cable (Kodi) are additional benefits. My needs are simple, and Infuse has been a great discovery!

I’ve managed to muddle my way through most things. The first issue I had was when I first downloaded the Infuse app to ATV. I created a share to the Macbook, and all went well. Then I downloaded the Mac OS Infuse app, and all my movies seemed to load, but wouldn’t play. It took me days to discover/realize I needed a local share to the Macbook to play movies offline. This maybe could be made clearer in the documentation (I did find it eventually) for non-expert users like myself. It’s obvious now, but seeing all the movie icons loaded up pretty on the Macbook, but not playing stumped me. “I’m just an old man eating stewed tomatoes out of a can”. :slight_smile:

I’ve managed to solve most of my metadata issues too. The weirdest was learning that for DVD files to show user added pics and fanart, they must be located outside the movie folder, in the enclosing media folder! Not intuitive to me, but now I know, and it works! I only mention these solved problems (of mine) as they might help another new user.

Now here’s my trivial issue: Out of 664 movies, I have two that won’t play locally while offline, but play fine (and display properly) on the ATV. (They will play locally if I choose the ATV share and am online). They stay in the “Other” category in my local share, and are “stuck” in “None-use embedded metadata”. This wasn’t always the case. One day the axe just fell. If I try and change to the TMDB correct movie that pops up, the gear icon just keeps spinning. The two movies are <Full Metal Jacket (1987)> and <The Tree of Life (2011)>. The folders and movies (mp4) are named the same, as I have done with all the others successfully. I tried adding posters and backdrops of my own, but that doesn’t help. I’ve refreshed metadata and scanned for changes multiple times. I figured it might be a TMDB problem, but since Infuse won’t let me select the movie, and they display and play fine on ATV, I’m asking here. I really wanted to compliment you on a job well done. I’m having a blast with Infuse!



Glad your finding your way!

What happens if you try to click here?
embedded

Or type in the movie name here?
embedded

No luck. I am running the latest Ventura, 13.1, but it works on every other movie I have tried.

What does it do?

In Settings, under General, Make sure “Embedded Metadata” is off also.

Embedded Metadata is/was off in settings. What happens? The gear icon starts spinning same as clicking elsewhere, and continues to spin without resultant check mark appearing.

I am wondering how you got “The Tree of Life” to be centered in the search field. For me, it aligns to the far left.

Do you have an internet connection when you see the spinning gear? It may need to finish syncing info before it can be selected.

That was just me adding text to your pic via the “Preview” app. :wink: In real life it would be over to the left. I was just lazy.

Yeah, I’m definitely connected. Downloading as we speak. :slight_smile: I even tried turning off my vpn, remembering when that interfered with my LAN until I realized (Thankfully, Mullvad has a local network sharing option). But no go.

I just now went to a random movie and changed it to “use embedded metadata”, then changed it back without issue.

Here are screenshots of my file naming convention. I use this on every film. I had two other films appearing in “Other”, Fellini’s 8½, which I had mislabled 8 1/2, and 9/11 (2002), which wouldn’t show up until I named the folder 9-11. Just so you can double check.
Screenshot 2023-01-06 at 1.53.10 PM
Screenshot 2023-01-06 at 1.54.15 PM

Are you changing it to embedded or local? Those are totally different things. Embedded is metadata that is actually contained in the file and Local is metadata that you have located in the same folder as the video. You do not want Embedded unless you’ve actually embedded the files youself into your video file.

OK you have hit upon a source of confusion for me. I did realize embedded meant “contained in file” as you state. But when I add local metadata, I found that it would not “take” until I simply choose “embedded” for a second, and then go back to “local”. Local meaning to me the movie icon with the never ending spinning gear shown in screenshots above. This is why or how these movies got stuck on “embedded”.

Leave embedded off and while you have an internet connection go to the Library settings page and click on refresh metadata. See if that brings in the missing ones.

Don’t set any of the folders or files to local unless you want to override the downloaded artwork.

I refreshed metadata, and I used my phone’s much faster than wifi hotspot data. Unfortunately, no change. Just those 2 movies.

Did you let it complete the fetching from the server and then finish the icloud sync?

Did the gear on the tree of life quit spinning?

Yes, and no. Gear is still spinning, still check mark on embedded metadata.

Please clarify how to “set to local” or unset. If I remove the checkmark from the metadata option (movie icon and title), it reappears when I right click edit metadata again.

For fun, can you try entering a different movie title (EG Titanic) into the search field, and selecting that?

If that works, then try navigating back and redoing the search with the correct title.

Tried that but same result. Spinning gear keeps spinning. I had tried that in the past. I also removed movie from my media folder, scanned for changes, synced with icloud, synced atv app with icloud, readded movie to media folder, and still same result.

Well, I’m happy to report it is mostly fixed. I got The Tree of Life unstuck after messing around with name changes and repeatedly refreshing metadata didn’t help. I went to the “Files” section via Infuse, and was able to select TMDB movie icon/title, getting it off “Use Embedded Metadata”. The TMDB artwork appears, but the movie still won’t play when my local share is checked and I am offline, or online for that matter. As I previously stated, if I select the ATV share and am online it will play on my laptop.

The good news is if I go to the “Files” section via Infuse it will play from there when offline. It’s the only movie that does this, but it’s so depressing I am having difficulty getting through it anyway. :slight_smile: Below is what I see when I click play in the movie (anywhere but in “Files”) using the local share. Anyway thanks for your time, and I am still thrilled with the app, and how it has rekindled my interest in film.

P.S. I procured another rip of Full Metal Jacket, this time an mkv file, and that did the trick for that title, using the same naming convention as before.

1 Like