Infuse speedtest results

Just wondering what results other people get when doing a speedtest in Infuse from their NAS?

I have a Synology DS412+, ATV 4K and gigabit connection.
I connect to the ATV via NFS, also tried SMB with gave me similar results.

My average speed is around 140 Mbps is that normal?

Yes that’s good. It’s not showing you a max file transfer rate but the max rate it can play a file given current network conditions.

How do I do that?

Test Connection on Shares for TvOS only. Must have 6.2.4

Have just completed it, my details are:
Zyxel NAS542 in the loft connected to a Netgear GS305 gigabit switch which is then connected with a cat5 cable to my router and the ATV 4k to that.
Only tried SMB (Auto) and on a few 30GB BR my average speed was 274Mbps, image uploaded of one of them.

img_6349.jpg

Synology DS215j on wired cat5e gigabit. Internet wired DLs to ATV 4K are around 300 Mbps. Max I can get from Infuse Speed Test is ~90 Mbps using NFS (SMB* gives me ~80 Mbps). I’m jealous of all the other speeds people are getting!

Perhaps you have a bad Ethernet cable, switch, or router. Internet downloaded don’t directly correlate to infuse playback speeds.

I am getting ~110 with gigabit backbone but wireless ac to Apple TV 4.

Understood, but the higher internet speed leads me to think it’s not a problem with the cables from the router to the ATV. Tried switching out the cables and ports from the NAS to the router and nothing has really helped.

SMB protocol as well as NFS have overhead. The plex protocol is purpose built for streaming and will always yield better speeds.

Maybe your drives are being slow or something else is accessing the NAS at the same time?

I am streaming from an iMac (late 2015 model, movies are located on the internal hard disk, no SSD) via two simple TP-Link Gigabit desktop switches and CAT.5e cables to my ATV 4K downstairs, yielding approx. 235 Mbps with SMB (set to Auto) and the same with NFS. During my tests I noticed that it’s obviously better to restart the ATV before testing (resp. watching a 4K movie), maybe to clear the internal memory? On some tests that I did WITHOUT a previous restart (i.e. when the ATV had been running for quite a while), I only received values around 50 Mbps. But after restarting the ATV and trying again, I received approx. 235 Mbps again.
Also, it takes a while before the bit rate goes up to 235 Mbps and stays there. During the first 1-2 minutes, I get around 150 Mbps with numbers fluctuating.

Best

Someone suggested trying FTP on another thread and it worked for me! Went from ~90 Mbps to over 300 Mbs! I would definitely give that a try.

…FTP?? You mean setting up an FTP server for Infuse? Does Infuse support FTP at all? Or did I get you completely wrong here?

Please explain…!

Best

Yes Infuse does support FTP. I’m using a Synology NAS so I just check a checkbox to enable FTP. Not sure what’s involved if you have to do it yourself but I think someone else mentioned successfully setting up an FTP server.

I getting about the same. I think my bottleneck is the Drobo. I have a CAT6 wired house from a gigabit switch and everything else is lightning fast except the files I have housed on the Drobo.

Never mind. I’m a liar. I just restarted my Apple TV after setting up FTP and it’s testing at 950 Mbps. That’s a crazy increase from SMB that was previously running at 60 Mbps!!!

Is there a specific reason not to use ftp? Seems like smb, nfs, and Plex were the most popular, but if ftp is so much faster, not sure why everybody isn’t using it.

Speed with my Qnap NAS:
SMB3: 150-180mbit
ftp: over 900mbit

Wired connection.

Because depending on your server OS, you might need an additional FTP server application whereas the SMB and/or NFS protocol is implemented in more or less all OSes.

Best

I’ve been advocating the use of FTP on the Apple tv for years, you can search my name on this forum. Apple’s implementation of samba has always been historically plagued with issues going back over a decade on their computers, you can look up the history. I think it all goes back to when samba went to GPLv3 open licensing. Apple moved to their own homebrewed version of samba. Read this link: https://www.osnews.com/story/24572/apple-ditches-samba-in-favour-of-homegrown-replacement/

There’s just too much overhead for SMB on apple products. While FTP has nearly no overhead, and you don’t really need much security inside your home for a multimedia share.

Most off the shelf NAS boxes have FTP built in, but yes for most everything else. You have to take extra steps to add an FTP file server.