Infuse shows all TV Shows in Others

Using Infuse Pro 6.6.3 on appleTV (14.4) and IPhone (14.4.2). Streaming from Synology Rackstation over SMB. Folders:
Infuse
—— Filme
—— TV Serien
———— Band of Brothers
—————— Season 01
———————— Band of Brothers.S01E01.Currahee.m4v
———————— etc.
—— Andere
Why does Infuse not recognize Band of Brothers as a TV Show? Every Part is shown in the Folder “Andere“!

Guess u’re german, right?

Well, I’m brazilian and, I’ll tell you how I’ve got it working here.

SMB:

/TV Series/Band of Brothers/Season 1/Band of Brothers S01 E01.mkv

So, at first, I’d recommend u try renaming “Season 01” to “Season 1”.

If it doesn’t work, the problem is on the filename. As stated by Firecore on 101 Metadata, the tv shows filenames must oney the following designation:

  1. show-name_s01e02.mkv
  2. show-name_s1e2.mkv
  3. show-name_s01.e02.mkv
  4. show-name_s01_e02.mkv
  5. show-name_1x02.mkv
  6. show name/any folder/S01E02.mkv
  7. show name/any folder/01.02.mkv
  8. show name/season 1/02.mkv
  9. show name/season 1/1-02.mkv
  10. show name/season 1/episode 02.mkv

Note: Period, space, underscore and dash can all be used interchangeably as separator characters.

*MY NOTE: maybe u shouls use spaces OR periods, not both of them.

*MY NOTE 2: If u have to rename lots of files, I recommend using NameChanger.

Please, tell us if this solution works.

Yes, I am german.
Nothing of this Works.
Season-Name changed - nothing.
Filename 1-5 - nothing
Filename 6-10 doesn‘t work with “/“

There is only “Filme“ & “Andere“ :cry:

Can you send a screenshot of the filenames/path?

Don’t worry, we’ll figure out whats going on!
Did u try deleting cache metadata? Are you using LOCAL or ONLINE metadata for that folder?

Path “Infuse“ is highlighted as Favorite in Infuse pro. The Filenames are Choas. I tested a lot today.

This structure and naming fetched the correct metadata automatically in a test.
Band Of Brothers File Structure and name

I know you said that you were using SMB but what you’re experiencing looks a lot like what you may see when using DLNA or UPnP shares, could you just double check the share type?

No, it does not. Already tested. File-Ending is *.m4v
Protokoll is SMB.
It works few months ago. After an Update, it fails. Don‘t know when.

Metadata deleted.
Only with Online Metadata tested. Nothing.
With lokal Metadata - nothing

Does Infuse show Band of Brothers when you select other?

DON’T ever use LOCAL METADATA on SERIES FOLDER… i tried setting up mine with your configs and, it worked; could u try renaming as “Band of Brothers S01 E01”, 02, 03…

Maybe try renaming the series folder to something different, scan, then rename it back, and scan again. Maybe it’s not picking up the filename changes?

How can I change this? It ever shows Local Metadata right above!

No, only each part with sx-ex

Add your tv shows folder to the Favorites, then click and hold on the folder and select “Use Online Metadata”.

Infuse needs all tv shows to be fetched with online metadata; even if u want to use customized NFO/XML metadata file, u must set the tv shows folder to Online Metadata.

Everything else can be used as local metadata.

Tell me if this works for you and, as I said, don’t worry, we’ll figure it out quickly. I’m watching the forum just to follow yr case.

WOW‼️
Thank you very much❗️There they are‼️
(Online Metadata)

Ok, so we have it solved, right?
Told you we were going to make it happen.
Glad I could resolve yr problem and… enjoy!

Please @james, @NC_Bullseye close this topic :slight_smile:

No need to close it.

1 Like