Infuse sees but cannot connect to SMB share; VLC, all others normal

And I keep pushing solution to SMB3 problem in this topic instead of possible workarounds because as far as I could understand @SoulsCollective , he is also not needing a workaround but a working SMB3 implementation.

Oof. I hope I’m not that unintelligible :stuck_out_tongue:

As above, I also have a workaround (DLNA or sticking with VLC). Also as above, I don’t want to spin up another daemon on the file server for a variety of reasons. Essentially my feelings on this are the same as yours, to wit, that I have paid for a product which advertises SMB3 support and would like for that to work.

I’m still around, just hasn’t been six months yet. I see it’s still work-around heaven. Dev’s have NOT addressed this issue at all and instead it’s everyone else’s fault. Period. Honestly, I’m moving on now.

Yeah sorry my point was kinda that VLC isn’t a work around, work arounds would be different sharing methods so you can use Infuse.

With respect you wouldn’t be posting here if you didn’t want to use Infuse.

I think I’ve spent probably just enough time before I annoy people suggesting to use other sharing methods.

Peace out :slight_smile:

Hi, first of all i’m probably less competent in the domain than most of you guys but had the exact same problem and you all might have tried this or not but sharing it : in the infuse app instead of trying to connect to the SMB that appears configure a new SMB adding the local ip adress of your PC/MAC/LINUX even onto an other name as long as the logins are good . voila that solved it for me hope it will help someone at least.

Just throwing in my own grief at this situation.

I don’t have a solution, but for the last year I’ve found myself attempting to share over SMB, and each time after several minutes of tinkering just caved and gave up due to lack of time. For the last month, though, I’ve been more serious about figuring out why, pouring several multi-hour sessions into this, and I’m stumped.

I’m also increasingly frustrated because like most people who have graduated beyond Single Male Basement Dweller, I can probably count in minutes per year the amount of time I actually get to myself, so pouring in so many hours into this just to fail every time is such a drain on my morale.

The most frustrating part of this, though, has to be that every other app I’ve used to connect to the SMB share does so flawlessly. I kept chalking up the lack of success to my own incompetence, but once I started testing with other apps, they all just worked.

Sharing to Infuse over SMB just does not work for me. This discussion seems to be the most recent and ongoing one, so at least now I can grieve with the others here.

For reference, this is what I’m using:

  • Infuse 7.6.1
  • MacOS Sonoma (14.0) with file sharing enabled

Any updates on this? Is the issue being investigated? Am I just going to be forced to start hosting various daemons again, which is the sole reason I moved away from all that complexity and settled on Infuse so many years ago now.


1 Like

Welcome to the club of the unfortunate afflicted :stuck_out_tongue:

Many updates of both TvOS and Infuse later and situation remains the same for me:

  • Literally everything else on our network can see and access the SMB share, across Windows, Android and *nix installs;
  • All other media players tested on the AppleTV can see and access the SMB share;
  • Infuse alone can see but not access the SMB share, regardless of what settings are used; but
  • Infuse can see and access the DLNA share on the same file server without any issue.

There is pretty clearly some specific issue with Infuse and SMB here. While I don’t mean to sound petulant, the fact that Infuse continues to advertise SMB support while providing IMHO pretty limited support to actually get this advertised feature working is somewhat galling.

1 Like

Wanted to move on but my email says otherwise. INFUSE-PLEASE RESPOND to the SMB sharing issue. Not long after purchasing lifetime license, SMB sharing stopped working. It is not on our end, we’ve spent days. This needs to be fixed.

Diagnostic code from an attempt to connect to SMB from Infuse on iOS: GN6PD

I encountered the same problem as you, but I found a solution and hope it can help you: In infuse, you cannot enter smb:// for the smb address. You will not get an error if you just enter the address number, such as 192.168.x.x.

Re: suggestions to specify IP address - at least for me, this does not work.

Attempting to specify a new ‘Other’ server in Infuse, then entering the IP address (either as or smb://, selecting SMB protocol, ensuring ports etc are correct, fails instantly with the same generic ‘Error’ message. I have again attempted to ensure SMB3 is specified, tried both guest and specific username/password combo, specified workgroup or left blank, all all other permutations I can think of - no luck.

Another thing to note is that there is a bug from Microsoft. If you use a Microsoft account to log in to Windows and later change the account password, SMB will not be updated accordingly, and you must use the old Microsoft account password.

Thank you, but not particularly relevant to this specific thread - the SMB shares here which Infuse cannot access are either on Linux or MacOS machines :slight_smile:

I had the same issue. As per my understanding, the problem is that Infuse is not fully compatible with the Samba’s latest version of SMB3.

Try to update your config with this line:
server min protocol = SMB3_02

The Samba has several versions of SMB3 protocol:

  • SMB3_00: Windows 8 SMB3 version.
  • SMB3_02: Windows 8.1 SMB3 version.
  • SMB3_11: Windows 10 SMB3 version.

By default SMB3 selects the SMB3_11 variant.

In my setup Infuse works normally only with SMB3_00 and SMB3_02 variants.