Infuse sees but cannot connect to SMB share; VLC, all others normal

Thanks for the new report. Based on this, it seems there is some sort of issue with SMB3 on this server and Infuse tries to fallback to SMB2.

When using SMB, it will try to connect at the highest level, and then fallback to a lower level if it is unable to connect. So, selecting SMB3 will use a MAX level of SMB3, but SMB2 and SMB 1 would also be options. However, this will not work if the lower versions are disabled on the server.

There are many different flavors of SMB used in different stacks, and these don’t always get along with each other since each has it own quirks. I don’t know the specifics aboun the SMB version used on this server, but it may be worth trying to adjust the minimum version to SMB2 instead of SMB3. This would allow you to both of the SMB stacks in Infuse (Auto, SMB3, SMB2, and SMB1 is one stack, and Legacy is the other stack).

As I mentioned earlier, there is little reason to require SMB3 for video streaming in a local network environment.

He mentioned he can’t enable SMB2 on his network, because that will cause a device his toddler daughter uses to fail to operate.

But DLNA shares are limited in library functionality, yes? Otherwise you’d be using it?

Have you tried NFS? Would switching to NFS similarly limit your use case somehow?

Good luck FLskydiver. I remember months ago on an Infuse update, SMB worked again from Mac to AppleTV. The next Infuse update, it went back to how it had been for the last couple years prior. I was so excited, for a hot minute. I have reformatted my whole system around this issue with Infuse being the very first thing I install before any other software-besides the required basics that come with Mac. I’m an IT guy, it’s not my router. It’s not my Mac. It is, indeed, Infuse. Like you, all my iPads, iPhones, macs, Apple TVs can see the share, just unable to access it. Same error message. Once upon a time this was very reliable software, soon as I bought the lifetime license, forget it. I’ll check back on this post in 6 months to a year and see where we are.

Thanks for the new report. Based on this, it seems there is some sort of issue with SMB3 on this server and Infuse tries to fallback to SMB2…There are many different flavors of SMB used in different stacks, and these don’t always get along with each other since each has it own quirks. I don’t know the specifics aboun the SMB version used on this server…

I appreciate the input James, but this is answered in the first post :slight_smile: This server is a custom build running Debian, using the industry-standard Samba package to provide an SMB share with the exact configuration file given in the OP. The underlying metal is an Asrock Rack EPYC3251D4I-2T, which features two Intel X550-AT2 NICs (set to bond in Debian). While I certainly agree that there are a whole range of NAS products out there all doing slightly different things, this isn’t a case of a strange vendor-specific config, this is straight Samba at all default settings except the SMB3 requirement, running on very standard server hardware :slight_smile:

As above, Infuse is the only client which has any issues. All other software clients on the same device (ie. the AppleTV) can see and access the share perfectly. All other devices on the network, across both Linux (Debian/Ubuntu), Android and Windows environments can see and access the share perfectly. Given this, it seems very unlikely that the issue is with the file server.

1 Like

He mentioned he can’t enable SMB2 on his network, because that will cause a device his toddler daughter uses to fail to operate.

Thankyou! To try and put this to bed: the media player in question is a very cheap PLAYCOM-brand knockoff tablet/player thingie sourced from a no-name vendor on AliExpress running some ungodly hacked up implementation of Android. It is terrible in most respects but has the huge advantage of being completely impervious to teeth, being smashed with toys, dropped down two flights of stairs, etc. This thing will survive the nuclear holocaust, and as a parent this makes it worth no end of dealing with ex-PRC jank.

It notionally supports SMB but the SMB2 implementation specifically is borked and fails to connect to anything. This is a known issue with this device from other user comments, so not a problem on our end. No software updates are available for this thing and the vendor has vanished. So this isn’t getting fixed. The workaround suggested by other users is to make it use either SMB1 or 3 instead, but this has to be mandated server-side because the device itself exposes no settings for this. I’m not willing to let SMB1 run on our home network, so SMB3 it is. This works completely fine for everything else in our house except Infuse.

But DLNA shares are limited in library functionality, yes? Otherwise you’d be using it? Have you tried NFS? Would switching to NFS similarly limit your use case somehow?

So, there’s a whole NFS-vs-SMB thing I don’t want to get into but in very general basic terms SMB is preferable in my specific instance because it’s more broadly compatible in multi-OS environments (we have everything in our house except MacOS) and the user-account based credentialling model gives a more consistent and easier to administer experience wherein all the less technically competent members of the household need to know is that they enter the same username and password on any device and they see all the same files in the same places with the same permissions and security and so on.

DLNA is basically just the ‘screaming from the rooftops’ approach to file sharing with no easy options for access control, specific shares for specific users, etc. So again kinda bypasses the whole ‘enter your username and password and you see the exact same thing everywhere’ benefits. Also from these forums Infuse library and metadata stuff doesn’t play nicely with it.

You misunderstood me. I’m not experiencing the problems you are. I’m just one of the many people here trying to help you that you’ve decided to blow off.

Understood. But can you not run both SMB and NFS at the same time? (You need only set up Infuse instances to connect with NFS, leaving everything else as is.)

Appreciate the input :slight_smile: And yes, I could, but this wouldn’t be ideal for a couple reasons. First, I’m not nearly as familiar with it, which increases risk profile and headspace cost for me in keeping our home network up for a number of quite demanding fellow users (some of whom have very limited patience). As a corollary, increases the chance I bollocks something up and hose files.

Second, I then have the same set of files being shared on the network via three separate protocols requiring three separate server daemons. While the EPYC 3251 should have enough grunt to handle this (along with everything else it’s also doing), this isn’t great from a performance or potential-for-janky-interactions perspective.

I do appreciate that you’re offering input as to how to get some level of functionality going, and am grateful for the input, but given I currently have a workaround in place via DLNA, I’m reluctant to spin up another.

Per documentation, Infuse should support SMB sharing, and it was on this basis of advertised features that I’ve now paid two months of subscription fees to the devs, so I’d really quite like to get to the bottom of why this isn’t functioning as it should rather than shrug shoulders at it :slight_smile:

1 Like

It might be worth trying to set the min version to SMB2 just to test and see if that works.

If you’re set on using SMB3-only there is likely something on the server (config, version, etc…) that Infuse’s SMB stack may not like. The logging in Infuse isn’t enough to debug this, and the only real way to troubleshoot would be to capture the packets via Wireshark and send in the full report.

If you want to head down this road, some info on doing this can be found here.

I will note, there is an update for the SMB stack coming in one of the next few updates, though I can’t say whether this will help with your particular case or not.

Whilst I may be out of line suggesting this I admit, I’ve not read every single word of every post but I wouldn’t be using SMB at all, for someone who had it working fine SMB is one of the slowest methods of sharing media to Apple gear, particularly the overheads of SMB3. Apple products are kinda crappy at dealing with SMB. I switched to using FTP, I just installed the free FileZilla FTP server and created a read only FTP account with only a username and no password (fyi I’m running windows 10 on my ‘server’). Infuse client will actually exhaust the wired network bandwidth and folks can watch 4K content in multiple rooms from the same file server, SMB would struggle to achieve the same and speed tests clearly showed a good 400mbps difference, at least in my testing.

I have been in this boat before, so adamant I need to use one solution and dig my heals in but you’re going to find a simple FTP server makes life alot easier without having to worry about differing platforms talking to each other.


On phone and will respond to other posts properly later, but with respect, could you please find another thread to be toxic in? I’m also annoyed that advertised functions aren’t working but this isn’t helping anything!

Edit: this post was directed at a comment above which now appears to have been removed by mods and was not directed at naylor2006’s contribution re FTP, which is appreciated :slight_smile:

1 Like

It is indeed a super pain when things that are supposed to work, dont with no real answer, what makes it worse is that other things on the same network are working so its easy to blame Infuse. In their defence I would say that whilst it is a fantastic product it doesnt come with its own server software so that part will always be down to us. Without providing its own file server ‘software’ Infuse is having to deal with 1000’s of different potential configurations and just wont cover them all.

So SMB 3.0 works fine for me Windows 10 → ATV Infuse, never guess what though, it doesnt work using VLC, weird things happen, I dunno why I didnt investigate it at the time it was before I knew about Infuse and for some reason I am anti Plex, probably because someone I fell out with at work years ago loved it so much and talked about it all day…kinda silly I admit.

Take my recent issue, Infuse wasn’t preventing my file server from going to sleep like it is supposed to when its open but not buffering, Infuse support told me ‘well it should work’, and I was like, ‘yeah but it isn’t dude’…can replicate the issue over and over and provided logs, I dont expect you to read my forum post of care about the specifics. Point is my environment was not acting as expected, just like yours and from the looks of it you are running, and please dont take offence, I slightly more custom environment. Sure other apps are working fine, even some crappy tablet so Infuse this gloriously pretty product should work fine. I fixed my own stay awake issue the end with a script. My post is here in full on the Streaming and Network, dont expect you to read it but the same sorta frustrations are there from me.

Like I said in my previous post, I started using FTP because its the fastest, its easy to configure, its separate from my normal SMB shares and doesn’t cause any conflict, im sure you could install this on your FileServer and do away with the SMB for Infuse, Apple have always been a little crap with SMB and given that Infuse is purely developed for Apple it doesnt surprise me there is some issue, VLC for example has been around forever and is far more likely to get on with SMB baring in mind that for a long period of time VLC was the go to for everyone on Windows were SMB is bread and butter.

1 Like

Thanks all for the several replies.

Re: further suggestions as to workarounds or alternate methods to get Infuse seeing files

I do appreciate the thought behind these suggestions and the contributions being made to help get this working for me :slight_smile:

At present, I do have a workaround in place via DLNA. So things are playing on the AppleTV; we’re not sitting in darkness bemoaning the lack of content to watch.

However, I don’t have the time or brain capacity to redo our entire home network architecture, be mentally prepared to support and troubleshoot three (or four!) separate file-sharing protocols if anything goes wrong, or try and train several less technically-capable household members with limited patience that they now need to look for different options or do things differently. We don’t have any MacOS devices in our house, but SMB works with the hodgepodge of everything else beautifully and is understood by everyone. The server read speed and bonded network interface is sufficient to stream 4K HDR trouble-free, and everything #JustWorks.

With sincerest gratitude for the inputs received so far, we’ve only recently set out to try Infuse after a long period being happy with VLC, we (I) only paid the subscription fees because it is advertised as being essentially a drop-in upgrade to our use case (ie. to support SMB), and we were happy enough using other apps beforehand. It certainly looks like it would be a nice way to stream to the AppleTV, and was general opined around Reddit and other forums I frequent to be fully-featured and reliable, all of which sounded great (although hasn’t been our experience to date).

However, we’re not so desperate to be using this one particular app that we’ll do anything just to get it to work, and if the end point here ends up being ‘Infuse does not actually support SMB’ then the outcome is going to be cancelling subscription and pursuing a refund rather than embarking on an extended campaign of tinkering to kludge together a solution that Infuse is happy with while paying for the privilege.

Great suggestion James, I should have thought of this myself. Appreciate you being willing to engage deeper on this. I’m currently typing this from a hotel room travelling for work, but will revert early next week. Any suggested filters as a starting point?

1 Like

Okay well my last word on this is then…

Setting up an FTP server and adding it to Infuse Clients is going to take an hour at most to complete. No one else needs support, I know what you mean, my wife is difficult like that haha, but she doesnt need to worry about FTP being there, it just sits in Infuse config once and its done. Having FTP doesnt mean you have to remove SMB or change anything else at all, everything stays the same, you just have to install your chosen FTP server on your media server, point it at your jazz and add it to the Infuse Client, thats a one time task dude and from my experience FTP is the best method of sharing to Infuse. When my daughter opens Infuse to watch her shows she doesnt need to know its connecting via FTP, its just always there in the config, in fact neither my wife or daughter even realised I changed to FTP for Infuse, the front end result is identical.

Okay, thats all I have to say on it, my opinion is that SMB isn’t wonderful to use with Infuse (although mostly works fine im sure) when there is a much better option in FTP. The reason I landed with FTP was due to trawling Reddit with my own gripes about SMB. Whilst I am not providing you a fix for SMB I am providing a better alternative as per your original post.

Enjoy the work trip dude and all the best for getting this working.

Edit: I know I said last word, I meant last words, perhaps paragraphs…

1 Like

While FTP may be the option that works best for you the vast world of variables in equipment and programs out there can make FTP a less than optimal choice for some. A blanket statement that it’s the hands down best isn’t always true.

SMP protocol can work very well for many users.

Hey dude, I think you took my comment out of context, I qualified it with ‘my opinion is that’, that kinda changes dramatically what im saying and does indeed refer to my personal setup.

I would also add that FTP is probably the most transitional, by that I mean is usually there on NAS’, can be installed on Windows, Linux or MAC and SMB is largely a Windows protocol. This guy was asking for alternatives so I just suggesting one. My research found that SMB was not great with Apple products, so I wasn’t criticising Infuse, I bloody love the product.

1 Like

Yeah, honestly, the only two things I ever had to do to set up my Synology NAS to work with Infuse on all my Apple Devices was to make sure a single toggle button on my Synology’s settings page was in the on position (either one of the two selected items currently shown as enabled in the following image); and to enter my Synology’s local IP address (as permanently assigned per its MAC address by my router) into the first Apple device I got around to setting up (iCloud later automagically synced the server’s IP details to all its compatriots):

Only needing Infuse to serve content to local devices within a single home Wi-Fi network, I personally detected no difference in performance between SMB and NFS during initial experimentation. Both worked, and I never had any need to try anything else.

I’ve since (more or less randomly, given what I mentioned above) decided to stick solely with NFS because it was easy, it has always worked, and it’s never given me any more reason to invest additional thought into it.


1 Like

Yeah, NAS’ make it so easy, my setup is just a large Windows 10 PC with 8 10TB drives in it, I’ve never tried NFS as it would be a touch silly to do so from a windows machine, but SMB is natively there and for me worked just fine.

The problem I had with SMB was that originally my Windows Server was attached to a Wi-Fi Mesh disk, the the extra over head of SMB plus the limitations of Wi-Fi was giving me about 500mbps, switching to FTP gave me 800mbps so I stuck with it as for 4K stuff I needed to squeeze out the performance a bit. Now everything is Ethernet so I could indeed switch back to SMB but I can’t be bothered as Infuse and FTP for me has been flawless for a couple years.

I think maybe my intentions were lost on this post, SMB is clearly causing the OP some troubling problems for Infuse and I support Infuse a lot, I recommend it to everyone and I want this dude to love it like I do, so was just suggesting FTP as an alternative to try.

1 Like

Felt it worth noting that SMB3 is (and has been for quite a few years) the default for Apple systems, with even Files app on iOS supporting it, and TimeMachine requiring it as the only supported protocol.

Anyway, I have the same issue, instant error. And had it for at least a year, maybe more. Code is 58P8X.

Configuration is Ubuntu running stock Samba v4.6.18, with settings adjusted for TimeMachine support and with min protocol version SMB3. I can’t enable SMB2 as then TimeMachine bugs out, and actually I don’t want to. I prefer my network traffic encrypted.

As for the packet captures asked here by the devs, let me just refer to those two webpages:

Just install it yourself and figure it out finally.