Infuse seems to corrupt media files (4k HDR)

Hello

I downloaded the last season of Punisher in 4K HDR but I got 2 episodes that stopped abruptly and moved to the next episodes. I looked and the file size shows Zero Bytes on my Mac. When I watch the episode in 1080p, no issue.

Is this a known bug and is there a way to solve this? Do you think it is due to the file itself?

Name of the file: Marvels.The.Punisher.S02E04.2160p.WEBRip.X265-DEFLATE

Are you by chance serving files from a Mac running High Sierra?

Hello there
Thanks for your message.

I use a Mac mini 2018 with Mojave. It is not the first time that I have this issue.

Maybe it’s because I downloaded the full season (90 GB I think) and not one episode at a time?

Is this the only file you’ve had an issue with? Also, do you have the mac energy saver set to allow network wake? Is the file on an external drive to the mini?

Trying to get an overview of what’s going on. :wink:

This sounds like a source/file issue. I’ve played numerous 4K files. The only issue I’ve seen is when there is a corruption of the actual file (which Infuse doesn’t alter).

Infuse won’t alter the files. You’re having some filesystem corruption. Is it the local drive, external USB, or NAS?

Just an FYI a similar problem cropped up before so we need the rest of the info I asked for above to make sure it’s not a returned problem.

Hello there

Thanks for all your messages. To answer the different questions:

  • it is not the first time it happened, I think it happened not only on 4K HDR as initially stated but sometimes on 1080p files, actually.

  • Energy saving settings are properly configured, see printscreen

  • The file is not on an External HDD, I don’t have a NAS. I Have an external HDD but it is only for music.

I believe it might be a corrupted source but it is weird because it happens only since a few month, since I started using Infuse and this Mac mini. I’ve read some similar posts but that was related to High Sierra and an update fix the issue.

I configured uTorrent to download the file in the “Download folder” and once finished in the Torrent file which is the only folder where Infuse has access to.

Any other suggestions?

Which version of SMB is this share using in Infuse (Auto, SMB3, SMB2, SMB1, Legacy)?

Hello James

I use SMB Legacy. I downloaded again the full season, but this time I didn’t turn off the mini. I have 7 episodes left, I’ll let you know if I encounter the same issue.

I had some errors on other file, but by restarting the Apple TV 4K, files could be played flawlessly. Not sure if related, though.

If possible, I’d recommend using the Auto option instead of Legacy. Auto is a much more modern SMB implementation, that is much more reliable.

Also, a number of speed related improvements are included in today’s 6.0.3 update, and these will only be available when using Auto.

Alright I selected Auto.

I still had issues so I ended-up watching in 1080p.

I have another show in 4K, I’ll try again later and let you know.

Also just to make sure, did you update Infuse to 6.0.3?

I think so, where can I check the version number?

The issue happened again just now, actually!

Go to the settings screen and scroll down to the very bottom and the version should be there.

It’s version Infuse Pro 6.0.3 (2540).

I’m also sending a diagnosis. The bug appeared around 9:40~10:10 PM SGT.

It looks like you are still using the Legacy SMB option (at least in the reports we can see from April 18 onward).

Please switch from Legacy to Auto. You can also remove and re-add the share and Auto will be selected by default.

Indeed, I swore I changed it to Auto. I tried again and put Auto. I restarted the Apple TV 4K and it was Legacy again. I followed your instructions and now it is in Auto.

I’ll watch more shows tonight and see if it solves the issue.

Issue hasn’t appeared so I guess it is solved, now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.