Infuse Pro on Apple TV - indexing failed for Macbook Pro

I’ve been using Infuse Pro on my Apple TV for a few months now and recently I got this error saying "indexing failed for Macbook Pro. I cannot play content and import new content to my library.

I’m using macOS Ventura 13.0 (22A380) and tvOS 16.1 (20K71).

Please help and thank you in advance!

try completely uninstalling infuse on macos and check if issue persists. there is a guide on how to completely remove infuse or you can use an app cleaner as well.

If you’ve recently installed an update for macOS, you may need to disable and then re-enable File Sharing to get it working again.

There are a also a few other things to check on your Mac.

  1. SMB is enabled on your Mac (more info here Set up file sharing on Mac - Apple Support)
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above)
  3. The folders/drives you wish to share are added to the list of Shared Folders
  4. Selected username and password are being entered in Infuse

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: Change Users & Groups settings on Mac - Apple Support

Tried all of that and also reinstalled the app on both devices.

I’ve tried and created a sharing account with a username and a password.
after putting that in the Infuse app on my Apple TV I’m getting an error saying “Sorry, Infuse encountered an error while trying to connect”.

It’s really frustrating, I’m paying for the Pro subscription in order to watch movies with my family and now it’s not even working…

You may also try one of the troubleshooting steps found here.

1 Like

It works!
I think enabling smbd in Full Disk Access did it.

thank you very much, have a wonderful day!

2 Likes

this also happened to me. i also needed to restart my mac after disabling full disk access and SMB and only after that it worked.

1 Like