Infuse pro dosnt work with wifi encryptation

Hi all,
I was using ipad peo over a year and was happy with it.
Im using ipad pro ver 9.3.3 no jailbreak.
After the last update infuse pro stop working for me.
When im open the progy it just close in a sec.
After i do a little reasearch i found out that the problem is with the wirless encryptaion.
When i set my router to open system all qorks fine but any encryptaion i put iget the problem again.
Iv tried with my old ipad 2 and same problem
The ver is 9.3.3 rhere too.
My router ia asus rt-3200
Any one so something like that?
The common is the same ver of ios and the router.
I even restart router to default but no luck.
With nplayer i dont have any problem and it works perfect,i can access to my plex media.
This is very weird problem

Any idea
Tnx in advance

i just wanna update that i cheked with dlink 880l router of a friend and the app works fine
what i don’t understand is why the app crashes when i try to open it when i connected to the internt ?
if i disable wifi the app opened without no problem.
i restore my router to default and tried everything i know
can someone pls advise

someone from firecore pls explain why the app crashesand wont start (blink and get close) when wifi is enable???

Can you check to ensure you’re running the latest 4.3.2 update? This had a few fixes for issues like this that were reported.

Hi James
I have the latest veesion 4.3.2
It started after the last update
I never had this problem in the past.
Pls fix it soon because i can’t use the app