Infuse Pro 6 Instantly crashing

Hi guys, all of a sudden my infuse pro 6 app started to instantly crash. I tried reinstalling it and even went as far as resting my Apple TV 4K with no avail. Help please.

Could be a problem with iCloud data. You could maybe try turning off iCloud sync on all your devices, then delete the data in iCloud from your iPhone iCloud settings. Then re-enable one by one and see.

Are you by any chance running a tvOS beta?

No im on alpha tvOS only.

Tried this and it still crashes instantly. I even reinstalled after turning off iCloud sync on all my devices.

I meant are you running a beta version of the operating system on the Apple TV. As far as I know there is no “Alpha” tvOS available to the public.

I work for Apple , the “alpha” release is the public version of tvOS, not the beta version nor the public beta. As I said before I’m on the current alpha version. Not the beta.

Sorry I don’t work for Apple so my limited knowledge concerning “alpha” releases meant that it was the version before “beta”, the first working version. Sorry about that. I take it you’re using the current version tvOS 14.4 (18K802) I think it is?

When it crashes, does it fall back to the ATV home screen or does it lock up and require a power cycle?

Do you mean you restarted it or reset it?

1 Like

One other thing to try, if you’re using the stand alone pro version of Infuse instead of the free version that will take subscriptions you could delete the pro version and as a test, download the free version and see if that will even launch and play some of the simpler videos without doing a subscription.

Yes I’m using the current version 14.4 on an Apple TV 4K. I’ve tried using all the versions of infuse free and pro with the same results. It worked before all the way up to yesterday, which is strange. I’ve reset Apple TV as well to factory and reinstalled infuse too. Same issue.

Any chance you could do a video of what happens when you launch it? If if falls back to the ATV home screen does it just do the exact same thing if you try to relaunch it?

Probably a silly questions but do other non apple apps work like VLC?

1 Like

And also to confirm. iPhone/iPad/Mac versions work okay? Just Apple TV crashing?

My Apple TV 1080, phone, both computers all work with infuse. It’s just as of yesterday the Apple TV 4K won’t launch infuse app. When ever I click on it it launches and a split second later crashes before it can even get to the screen. All
Other apps on Apple TV 4K work

Yes all other apps work. How can I post a video here? But a video won’t do much show you exactly what I’m saying. I launch infuse it try’s to open but in half a second crashes. The end. It’s an Apple TV 4K on a 4K tv. It worked for weeks and now it does this.

When it crashes, what does it do? Does the screen go black and you have to unplug the ATV or does it just return to the ATV home screen?

If you’ve done both a “reset” and a “reset and restore” and you still get a crash after both of those actions but you can run infuse on other ATVs and devices it really points to something on that specific ATV.

It may be a hardware problem.

Maybe try turning off match content frame rate and dynamic range and see?

  1. It returns to the ATV screen.
  2. Its clearly not a hardware issue when every app still runs, including Infuse pro 5
  3. This Apple TV is (as ive stated before) a 4k model, and other devices are not. That clearly points out to the app having an issue with the 4k models, or HDR push through.

Firecore has a clear bug and nobody is responding, hence why im in this forum.

Are you using multiple Apple IDs on this device by chance?

If it’s crashing that fast, it seems like it may be App Store permission issue (IE the default Apple TV user with store account does not have access to the app).

If possible, you may check to ensure the default Apple TV user and store account on this device is set correctly, and then re-download Infuse from the App Store.

It has and always been just my Apple ID on this device. Your hypothesis doesn’t make any sense, if you read the whole feed, so I will repeat. It worked before Nothing on our end changed on the device. On all devices it works except the 4K Apple TV (apple Mirror’s devices to be the same), where the issue is. I restored the device, I downloaded and reinstalled Infuse and same issue still happens. Infuse 5 pro works fine (I dont normally keep both versions but I was testing out if it was only a ver. 6 issue and was correct). The device passes all Apple Hardware tests (Im an apple Employee). The only difference in this apple device and the others I own is its Apple TV 4K model.