Infuse Pro 3.1: AirPlay not working

Streaming AirPlay from a WebDAV server has stopped working altogether with Infuse Pro 3.1. I’ve tried it on two devices both of which worked reliably using 3.0.2: an iPhone 5 and an iPad Air. Neither work now on any file. Usually, an initial image shows and then moves in slow motion with no sound.

The files play fine on the devices themselves but won’t stream to the Apple TV. I’m downgrading to 3.0.2.

Can you try disabling the ‘Dolby over AirPlay’ option found in the Infuse sidebar settings screen?

I’d like to, but I’ve downgraded and upgrading/downgrading again would be a pain.

When I try to AirPlay with the Dolby over AirPlay option switched on my video will either not play or there would be a loud noise as the video plays (like a machine gun)

When I turn the option off the video and audio plays but there’s a significant audio difference, almost as if I’m listening to it through a can or something?

Is there anyway to get Dolby over AirPlay to work?

Also I downloaded Infuse and upgraded to pro through the app but I noticed mine says version 3.0 even though the latest is 3.1? I have no available updates…

Dolby over AirPlay is only available if your Apple TV is connected to a Dolby compatible device.

The 3.0 version number being shown in the sidebar is a bug, and will be fixed in the upcoming 3.2 version (which is currently in review at Apple).

My ATV is connected to my Panasonic BTT182 which is a Dolby compatible device. It will play the movie with Dolby over AirPlay selected but with no sound, as soon as I switch it off the sound kicks in. Any ideas?