Infuse Plex Poster update

Adding Ability for infuse to check plex for serverside chosen movie coverart, if no match is found

1 Like

Can you explain a bit more?

For me infuse is pulling whatever cover art is selected in Plex

For me it is not doing that. If i have a movie, usually it is part of a collection. recently i started using collection covers from, however, if i use those, infuse will display these movies with just a black coverart (no image). if i manually rescan plex through infuse, the black coverart does not change.


For me Infuse is pulling the covers I assigned in Plex. Not only cover art for the single movie but also collection posters.

Perhaps you can create a bug report and post the code here

For me it somehow is not, unless i disconnect the server and then re add it and re scan it (of course after i changed the coverart serverside prior)

The old issue has returned, ive got multiple movies with a black coverart again, refresh does not seem to work, as well as a fresh library import (latest version of infuse on IOS)

Infuse should be pulling in the current poster art assigned in Plex at the time the item was originally scanned.

If the poster was updated in Plex at some point, you can use the Refresh option in Infuse for a particular item and Infuse will fetch the latest details from Plex.

I have done that multiple times (also stated above), even on a fresh install and it still does not fetch the poster.

The black posters are still there…refresh does not work

I don’t want to derail your thread but could you provide a screen cap of what you’re seeing? Also, what file format are the posters you’re downloading being saved as?

Sure thing !

So first here’s what I tried (did not work at all)

My library is connected via Plex, so accordingly Media and meta should be fetched from Plex.

  1. added via Plex, some art did not load so
  2. tried individual refreshes, which did not solve the problem
  3. cleared cache and re-scanned the library via settings
  4. clearing the cache did not work so
  5. removed connection and re added the Plex server, did not solve the problem

Here’s an example (screenshot attached)

Cover art is either jpeg or png which in some other cases works but for the majority of movies (with black covers) does not work at all

The black images you are seeing indicate Infuse is unable to find a poster for these items.

Does using the ‘Refresh Metadata’ option in Plex and then the ‘Refresh’ option in Infuse for a particular item have any effect?

Can you tap the Settings > Email Us option and post the 5 digit code you see here?

James, I appreciate the input but please refrain from the refresh option, as i have mentioned it multiple times now that it does not work! Refresh meta on the plex side works as it should, and inside of the plex app everything was matched, including meta as well (so that side is ok), i do not know what is causing the issue on the infuse side, as i really like the app and want it to work also, but this issue has been persistent for me and is making my experience suffer as a result

Right, I know you had tried the Refresh option in Infuse…but I was curious if doing it after running the Refresh option in Plex had a different effect.

If you can send in a report (steps in last post) we can look further into what is going on here.

Edit: Got your PM with the code. Thanks!

Quick update.

We’ve looked into this, and it seems Plex is acting strange here.

All of a sudden, Plex is returning TMDb URLs instead of the actual artwork from the library. What’s worse is that these URLs are (insecure) HTTP. iOS App Transport Security (ATS) doesn’t permit use of HTTP since iOS 9 (with some exceptions) and thus Infuse is unable to retrieve the artwork.

We haven’t seen a case like this before. Are you using plugins, custom library settings, or anything special in your setup?

Nope, nothing pure vanilla Plex

Just doing some digging here, don’t want to clutter the thread but could you say what Metadata Agent you have selected in Plex?

The standard agent (movie db), it’s not just only me, I’ve seen multiple posts similar to this one

Didn’t think it was just you, I’m just trying to look through and see what may be different in settings for some that are having this issue. :smile:

Just to clarify, are you using the Plex choice in Movie agents and in that setting TMDB as the source or are you selecting The Movie Database Agent which only searches TMDB?

This is what I’m using