Infuse + Plex: audio and subtitles issues

First of all, yesterday I purchased an ATV4K just after reading that now Infuse can connect directly to a Plex server, so… it’s your responsibility! :stuck_out_tongue:

My setup:

  • I’m from Italy (more on this later)
  • I’m running PMS on my NAS (QNAP TVS-871). I’ve a lifetime PlesPass (if that matters)
  • I’ve about 1300 movies and 12000 episodes of TV shows (anime, cartoons, TV series)
  • I used to watch my stuff with an Android box (Minix U1) with XMBC and the official Plex Kodi plugin.
  • I’ve Yamaha RX-V381 A/V receiver
  • I’ve an old Samsung TV (no “smart” functions, no 4K, no HDR) that sooner or later I will change

With my previous player I could easily have the “On Deck” feature (really useful) and obviously the watched/not watched status is “in sync” with PMS. Everything was “good enough” to enjoy my video library but I really wanted to try the ATV and only the bad reputation of the Plex player for tvOS and the limitation of the ATV on supporting video/audio format prevent me to jump on this train (I’ve already an iPad Pro 10.5 and an iPhone 8 Plus so…).
When I read “Infuse can now have direct access to PMS” I run to the local Apple store to buy the ATV.
I’ve set it up, installed Infuse, purchased the lifetime PRO subscription (yes, I’m an optimist) and connected Infuse to my PMS.

The good:

  • beautiful interface
  • great integration (but I miss the “On Deck” feature)
  • great video/audio quality

The bad:

  1. for all my files I carefully selected the “correct” audio / subtitles track. Infuse simply ignore this (more later)
  2. on Plex I’ve multiple libraries (one for Anime, one for Cartoons, one for music Concerts, one for Movies, one for TV Shows) and in Infuse I have to setup up these as “Favorites” since Concerts and Movies are displayed together in Movies, and Anime/Cartoons/TV Shows are show in “TV Shows”.
  3. audio passthrough (I know it’s a tvOS issue right now)

For point 2, it’s a minor issue but I would like to rearrange the items on Infuse so I could move the favorites on top, if Infuse can’t (or won’t) handle PMS libraries

For point 1, this is the problem:

  • I’ve files with multiple italian audio tracks (DTS, AC3). in Plex I carefully selected the “best” one (like DTS) but Infuse ignore this: it will always go with the first italian track
  • I’ve files where the italian audio track is marked as “unknown”. Even if this is the audio track I selected in PMS Infuse will play the english audio track
  • I’ve carefully selected the proper subtitles track (usually “none” if not necessary, “forced” when present). If I choose in the Infuse’s settings to not show subtitles, nothing is shown (this seems obvious, but I read in the forum that with subtitles set on “no” Infuse will display the forced one…?). If I choose to show the subtitles, Infuse ignore again what I selected on Plex and simply displays the first “full” italian subtitle. It never (never) show the forced one, even if that track is correctly marked as “forced” in the file.

With my previous setup I had no issue with the audio/subtitles tracks: it always played the ones I selected in PMS.
With Infuse I have to manually select the correct audio/subtitles track for every file I want to play.

And you can understand that with 1300 movies and 12000 episodes already carefully configured on PMS, it’s a pain to do all the work once again.

I’m the only one with this issue or it’s a known problem that will be fixed in a future (I hope not so far in the future! :slight_smile: ) release?
thanks and sorry for the very long post!

No comment? :frowning:
I’m the only one with these issues?

I can confirm the issues with the forced subtitles. They are never shown, only if they are selected manually. See Problem with forced subtitles

1 Like

ok thanks!
the big issue for me is that Infuse ignores the audio/subtitles track I selected in Plex. if the same issue happens when Infuse has direct access to the files is even worse.

I am using Plex, too.

ok, so we are on the same (sinking?) ship!
let’s hope for a fix!

The other person is talking about forced subtitles not working for them,

I think you’re talking about your subtitles you have chosen in Plex not being the same in infuse, Correct? infuse is independent from Plex when choosing subtitles for a movie.

I’ve issue not only for the subtitles (and this IS an issue) but with audio tracks also.
Infuse “ignore” the ones selected in Plex and goes for the first one that matches the system language (when set to “AUTO”) even if it’s not the “best” option (and in files where the audio is marked as “unknown” it goes for the english track).
Since I have a lot of files and for all of them I selected the correct audio/subtitle in Plex, it’s a shame that Infuse simply ignores this and go on its own way.
I don’t want to choose the correct audio/subtitle every time I play a video or start from scratch for all the 13000 files once again!