Infuse plays stereo audio as 5.1

Same here.

I solved it temporarily by restarting both the TV and Apple TV, but that’s not a permanent fix obviously.

Thanks for your confirmation. You should try to shutdown the Infuse app via the Apple TV task manager and then restart the app only (Press home button 2x, browse to Infuse app and press up 2x). This is not the final fix either, but it’s a little bit easier and more convenient than restarting both the TV and the Apple TV.

1 Like

I ran some tests with the following results::

Test 1: step 1, audio 5.1 (AC3) - number of output channels 5.1, this is good, step 2, audio 2.0 (AC3) - number of output channels 5.1, this is not good, step 3, audio 2.0 (AAC) - number of output channels 2.0, this is good.

Test 2: step 1, audio 5.1 (AC3) - number of output channels 5.1, this is good, step 2, audio 2.0 (AAC) - number of output channels 5.1, this is not good, step 3, audio 2.0 (AC3) - number of output channels 2.0, this is good.

Test 3: step 1, audio 5.1 (AC3) - number of output channels 5.1, it’s good, exit the program, close the application, then enter and start a 2.0 material - number of output channels 2.0, it’s good.

I did the experiment several times and this was always the result, I didn’t have to restart the device.

The phenomenon of stereo outputting as 5.1 after switching between tracks is present in other apps as well, and appears to be system issue.

We’ve tried a few approaches to work around this, but have not found any success.

5 Likes

A post was split to a new topic: Apple TV Setup

I have sent a feedback to Apple about the Stereo/5.1 sound problem in tvOS 16.

If they (Apple) would allow bitstreaming then they wouldn’t have to solve this bug :innocent:

Any change with 16.3?

Test with tvOS 16.3:
Audio setting DD 5.1 (change format): No Change, no return to stereo after a 5.1 sound output (only after app restart).
Audio setting Automatic: Correct change from Stereo to Multichannel LPCM and back to Stereo (Even when changing the audio track while the video is running).