Infuse plays stereo audio as 5.1


I have an Apple TV 4K 2020 (TvOS 16.0), an LG 32LM6300PLA TV and a Sony STR-DH590 AV receiver.

Apple TV and TV are connected via HDMI - HDMI2, AV receiver and TV are connected via HDMI-HDMI(ARC).

Audio is set to Dolby Digital 5.1 on Apple TV.

I am noticing a problem with audio formats.

For example, if I play a movie with 5.1 surround sound (AC3 5.1, DTS 5.1), everything is fine.

However, a stereo-only movie (AC3 2.0, for example), the Infuse plays movie also as Dolby Digital 5.1 (and only plays sound from the 2 front speakers, receiver shows 6ch input, thats wrong).

I tried changing all possible settings, including connecting the TV and AV receiver via an optical cable, nothing helped.

The solution is to set the audio output to stereo PCM, but then I lose surround sound.

Thank you very much for any advice.

Best Regards

Have you tried setting the Apple TV Audio Format to Auto?
Seems you may have locked your Apple TV into 5.1, regardless if Infuse is correctly passing it a 2.0 track or not.

1 Like

Tried, nothing changed.

Your going to want to leave the ATV on Auto so at least it will let apps change it.

Did you do a restart on the ATV after changing the Audio to auto?

Tried restart after set Format to Auto, nothing changed.

YouTube app plays videos as PCM 2.0 correctly, strange. Disney+ and HBO Max plays movies with stereo as PCM 2.0 too, but if I play movie with surround sound first, I get same problem, but force close and open app again solve it, then I get PCM 2.0 in stereo sound movies. In Infuse not.

Do these videos have multiple audio tracks? You can view a list of what’s inside the file by swiping down and viewing the Audio tab of the Playback Menu while a video is playing.

1 Like

Some yes. I tried switching between AC3 2.0 and AC3 5.1 track but the output is still 5.1.

Same problem here. All 2.0 video tracks are played as 5.1 or multiline. tvOS 16 and current infuse Pro app version.

Could you provide a bit more details?

  • which version number of Infuse and MacOS, iOS, or tvOS version.

Since there are frequent updates to both Infuse and the OS’s some users may be a version or more from current and not realize it.

Also what are you settings in the ATV settings for Audio?

How is the ATV connected to everything? ATV > Theater Receiver > TV or ?

You’re welcome, here are the details:
Infuse 7.4.6
tvOS 16.0 (20J373)
Apple TV 4K 2nd Generation
Connection: ATV via HDMI → TV LG NanoCell TV NANO91 (55NANO917NA) via HDMI eArc → AV-Receiver Denon AVR-X1600H DAB
Plex Media Server
Audio setting ATV DD 5.1 (change format) → 2.0 sound in Infuse is played as 5.1 in Denon AVR
Audio setting ATV Multichannel LPCM (no format change) → 2.0 sound in Infuse is played as Multichannel LPCM in Denon AVR

With my other streaming apps and the current version of plex app on ATV the sound is played correctly. lipsync with infuse 7.4.6 is ok.

Still the same problem on tvOS 16.1 (20K71).
MrMC App 3.9.12 plays sound tracks correctly on ATV.

Same thing on my old lg smart tv

1.0 sound is also played as 5.1 / multichannel.

I have the same exact issue.

ATV 4K (1st gen 4K ATV) > Samsung TV via HDMI, Sonos connected via eArc to TV.
Samsung, ATV, Sonos, all on latest updates.
ATV audio set to “auto.”
All 2.0 and 1.0 audio is 5.1 DD from Infuse.
Same files on Plex play at their native audio.

Still the same problem with today’s new version 7.4.7.
But thank you very much for the new audio delay function!

I’m new here and I just want to say that I have the same issue.

I have an Apple TV 4k.

When I force the audio on my ATV to Stereo, the sound is OK.
When I then switch back to Auto, the output stream is in Stereo so everything seams to work but when I play some 5.1 audio after that, the output stream is stuck on 5.1.

So I believe that there is some problem between Infuse and ATV.

Unfortunately still not fixed (Infuse version 7.4.9).

You may want to check your Denon settings since it’s possible for the amp to simulate 5.1 from mono and stereo settings.

I have a denon that does this too based on the settings.

I don’t think that the settings of my Denon amplifier are the problem. Up until tvOS 15, everything was output correctly from the infuse player. Under tvOS 16 all other apps (e.g. all streaming platform apps and also mrMC) output the sound correctly, i.e. 5.1 as 5.1 and stereo as 2.0, only infuse does not.

Just showing how I recreated your symptoms with receiver settings.

Since there are only a couple of users with this issue it doesn’t seem to be easy to recreate.