Infuse on Apple TV won't connect to Plex unless I enable Remote Access

My ATV is supposed to be on the same wireless network as my computer, where my Plex server is. But just recently, I started getting a “bandwidth” warning when I started to play the files. It looks like Infuse will not connect unless I have VPN off AND enable Remote Sharing (I couldn’t get Remote Sharing to work with VPN). Note that I have been using this set-up for years and have not had a problem until a few days ago.

Now, with VPN off and Remote Access enabled, when I play something on Infuse, it shows as Direct Play on the Plex dashboard, but the IP is the one listed as Public in Remote Access.

Not sure if related, but I have also tried connecting Infuse directly to the iMac via SMB (created a sharing-only user etc) but it would not connect.

Can anyone help me troubleshoot this? How do I verify that ATV/Infuse is “on the same network” as my iMac/Plex Server?

I can’t figure out how to edit my original post, but I wanted to give some screenshots.

Here’s what it shows under “Remote Access” on Plex, and what is on the dashboard when I play something on ATV:

Isn’t this “wrong”? If both my iMac (where my HDD is plugged in that contains the files) and the ATV are on the same wifi network, shouldn’t the IP shown be the Private one and not the Public one?

Okay so for posterity… I solved it. I had to forget the wifi network on the ATV and log back into it. Now when I play a file, it shows the local IP on the Plex dashboard, and I’m also able to connect to the iMac via SMB.

I am also able to play files now even though my iMac is on VPN.


Thanks for the follow up and solution! I’m sure there will be other users who end up on the same path and will much appreciate your solution. :+1:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.