Infuse on Apple TV and Sonos speakers

Hello,

I’w writing to let you know about a strange bug using Infuse Pro 6 on the Apple TV 4K and a pair of Sonos One SL Speakers. Indeed, using standard settings causes a lot of cuts on the sound, so I can’t watch a show or movie without having some cuts on the audio rendering.
I found a workaround but it can’t be durable as it involves using a legacy setting, which is the legacy mode for cache steaming.
I also have to force the audio conversion to Dolby Surround on the Apple TV audio/video settings.

Noticable fact is that this problem only occurs with Infuse, using VLC or Plex on the Apple TV I have no problem with the sound on my Sonos speakers.

So I think that for whatever the reason, the new streaming cache mode is not functionning properly using airplay 2 speakers, at least for some Sonos speakers.

Any help will be appreciated to find a definitive solution to this issue.

Small update. Further tests isolated the problem on the only “legacy” method for cache streaming. Indeed the playback is working fine whatether sound setting is set in the Apple TV part when legacy cache streaming mode is on, so I switched it again to “Auto”.
But setting back the cache streaming method to “auto” in Infuse is causing the sound issue during playback after about 30 seconds to 1 minute playback (it is working well at sart).

Thanks for the report.

We’ll look into this.

Hello, today I received the new Sonos Roam speaker, wich, indeed, I have already tested to see if the problem still occurs… and yes it is… but, as this speaker supports both Airplay and Bluetooth, I have tested in Bluetotth mode, and… problem gone. So it is really due, somehow, to the Airplay protocol.
Problem still present on the last beta version of Infuse 7.
Any idea of what could be wrong ?

Good to know @edel. I was wondering if I should buy a pair of Sonos One to use with Infuse. Now I’m gonna wait for this bug to get fixed. Watching this topic.

Hey, @james, is there any development?

I am experiencing a similar issue with the same set up. I also noticed some video files refused to play at all when the audio output is set to the Sonos speakers, but worked fine when set to TV audio. Seems like changing the cache mode to legacy fixed the issue. Any new updates on this?

Welcome to the forum!

So just to be sure, you’re using Infuse Pro version 6? What’s the complete Infuse version number and what tvOS version?

Thanks! By same set up, I meant same hardware. I’m using Infuse Pro 7.2.1 (3874) and tvOS 15.1.1 (19J581). The Sonos speakers I’m streaming to via Airplay 2 are at firmware Version 13.4.1 (build 66423300).

Does setting the cache to “legacy” solve the issue?

Yes, it appears so. I’ve tried switching back and forth a few times and the issue seems consistent.

Then I’d say just leave the streaming cache set at “Legacy”. That’s primarily the reason for having that option is that certain combinations of devices and transfer protocols work better using the legacy setting. Having to use the Legacy setting doesn’t mean you have a problem elsewhere.

OK, that works for me. Thanks for your advice!