Infuse on Apple TV 4K buffering - Shared Plex server

I’ve scoured various threads without success, and I’m reaching out in the hope that someone can shed some light on my current Infuse streaming dilemma.

My friend generously shares his Plex server with me, and until tonight, I’ve never encountered buffering issues. However, now I’m experiencing intermittent buffering, occurring roughly every minute. Interestingly, if I pause for a while, it takes a bit longer before buffering resumes, but the issue persists.

Here are the key details:

Media Storage:

  • All media is stored on a NAS with an internet speed of 500/500 mbps.

Movie Details:

  • The specific movie in question has a bitrate of 65,000 kbps (80GB). Notably, I had no issues streaming a movie with a bitrate of 50,000 kbps just two days ago.
  • Codec = HEVC
  • Container = MKV

Internet and Connection Setup:

  • My internet speed is 500/500 mbps.
  • Apple TV 4K is connected via cable to a Netgear router (R6850), which, in turn, is connected by Ethernet (no Wi-Fi involved).
  • The TV is a decent Samsung model.
  • Using Infuse Pro 7.6.3

Speed Test:

  • Conducted a speed test in Infuse with 5% progress on the file.
  • Average speed: 40 Mbps with occasional spikes up to 60 Mbps. Could these spikes be contributing to the buffering?

Now, the burning questions:

Friend’s NAS Upload Speed:

  • Could the buffering be attributed to my friend’s NAS upload speed not being robust enough?

Simultaneous Streaming:

  • Is there a likelihood of issues if someone other than me is streaming from the server simultaneously?

Potential Local Causes:

  • Could there be any factors on my end causing the buffering?

Other files:

  • Same problem occurs with other files in the same size.


  • What happens if the “quality” of the file is simply to large? Won’t Infuse transcode at all?

I’m grateful for any insights you can provide, and I’ll update with more technical details from my friend once I receive them. Thank you for your assistance!

That’s approaching the very lowest viable speeds.


Very possible

Sure, your internet speed, lags, network issues, improper settings in Infuse… etc

Infuse doesn’t do any transcoding at all.

Has your Infuse completed a scan of their Plex server?

If you pause the video right after starting it, and wait a few minutes does it play better?

Could you please elaborate on this? What does this average speed indicate for this specific file when running a speed test? Are you saying that the speed needs to be much more higher then 40-60 mbps since the file is in 65 mbps?

Please forgive me for what might be a stupid question, but if both my friend and I have 500/500 mbps and the movie has a bitrate of 65 mbps, shouldn’t that be working smooth?

I’ve tried being the only one playing something as well and the issue persists.

Are there any improper settings in Infuse that comes to mind that I can take a look at?

No, the scan isn’t completed. Could that affect it somehow?

Yes, it plays better but the buffering comes back after a while.

Thank you for your help so far! :slight_smile:

Realizing I’m in a bit of a tricky situation here…

Infuse is giving me buffering headaches when trying to watch the movie. And it can’t be played at a lower quality. Plex app, on the other hand, presents lip sync issues. The silver lining is that I can transcode the movie in Plex, but that doesn’t fully resolve the overall problem.

Feeling a bit stuck on how to navigate this situation. Any advice or suggestions would be greatly appreciated! :sweat_smile:

Some more information:

What do you have for your Streaming Cache setting?

Looking at the graph you provided there appears to be a network speed issue with all of the drops to the sub 20Mbps.

When playing videos in Infuse, the quality will always match that of the original video - without any transcoding. This is a little different than the Plex app which may adjust quality on the fly to get around low bandwidth issues like this if they appear.

When running a speed test in Infuse it will test the actual network pipeline from the source to the Infuse app. If you are seeing less than ideal speeds here then it means there is a bottleneck somewhere in the chain.

This could be a number of things, including: Wi-Fi or Ethernet cables, router settings, network/streaming settings in Plex, etc…

Also, since the server is remote, things like modem, ISP, and upload/download speeds come into play. The same things to check would also apply to the location where the server is located.

Right now it’s “Auto”. Which one would be best in this case?

When I use another Speedtest (by Ookla) it gives me info that my down/upload speed is 500/500. But when running the Speedtest in Infuse of the specific movie it is much lower as you saw in the pictures.

Just so frustrated right now that I can’t enjoy a movie and I don’t understand what’s causing it… :frowning:

Here’s also a picture from my friend’s server. Don’t know if that helps. My friend has also mentioned that it’s weird that it shows that the movie is streamed locally which, according to him, isn’t correct. But he assumes it is because I’m registered as a local admin of the Plex server. Could that affect the speed?

Another picture from his Plex server. Here it does say “Local” and it’s mentioned that both audio/video is Direct Play:

Skärmavbild 2023-11-18 kl. 19.52.17

I’ve tried pausing immediately when playing the movie. Paused for 20 minutes which bought me approx 13 minutes of watching without buffering.

That’s why seeing what real world is with the speed test in Infuse helps more than Ookla. Ookla is just a raw speed test.

As James said,

It could be your ISP, or server settings.

I’d suggest setting up a local server and trying that. It appears that sharing your friends is being hampered by one or more of the above listed possibilities.

As to the cache setting I’d try all of them and see if you get any better results with one of the others.

I’ve now tested on my own local server and the average speed ends up on 90 mbps which is more then double the speed I get from my friend’s server.

I know it’s difficult but would you say that this rules out that the “issues” is on my end? Could it be that when I’m using my friend’s server the movie “travels” a long way until it reaches my tv causing the speed to be around 40 mbps?

There is a vast number of “possible” problems with remote server use. What it all boils down to is first the only things you can change are the server settings, your settings and equipment, and lastly changing internet providers and “hoping” their problems are less and not more.

Plex in itself has a ton of settings that in one way or the other could cause poor speeds but that’s for the plex user to figure out. :wink:

You’ve proven that your system can handle things fine with a local server so the issue lies in the rest of the plex server loop.

65Mbps average bitrate for the movie is well above the 40-60Mbps you say you’re getting on speed test, so, yeah, you’re going to get drop-outs and stuttering.

Your connection could be going through the plex proxy for remote connections. There’s a setting somewhere on the server that can disable this. If this is turned off port forwarding will need to be enabled on the router.

I will ask my friend to see if there’s anything we can do to shorten the “distance” the movie “travels”.

Do you know where? :slight_smile:

Not sure if relevant, but once I got the issue Infuse playing 4K UHD media from my NAS.
Apparently the issue was caused by a switch/router for some reason establishing 100Mb/s connection instead of 1Gb/s. It took me a while to realize that.
I’ve restarted switch, confirmed it was back at 1Gb/s and all started to work again smoothly.

Per numbers 1GB/s is plenty of bandwidth for transmitting 4K UHD images over wire, while 100Mb/s in peaks is not be enough (UHD per spec can get to max 144Mb/s)

1 Like

Under network. Enable “treat wan ip as LAN bandwidth” and make sure “enable relay” is turned off. After that log into your router/firewall and make sure your remote access port is open and redirected to the internal IP of the plex server.

Thanks for the response! No issues with the switch according to my friend.

Is it me or my friend who should do this? He has “enable relay” turned ON.

Same here. Is it me or him who needs to do these changes in Plex?

These changes need to be made by him. They are done on the server that is sharing content.

The relay is the bottle neck. What this does is allow you to share your plex server without punching holes in your firewall however this routes all your traffic through a plex owned proxy server which is notoriously slow.