Infuse Not Releasing Storage Space on ipad

I recently downloaded (synced) 300GB of content from my Google Drive to my iPad Pro. I’ve now deleted the majority of it from the iPad, but it’s setting still show Infuse of using 300GB.

When is this free space returned to iPadOS?


Are you using the Files app to delete? If so, go to “browse” and look for “recently deleted”.

No, I’m deleting the media from with Infuse

Did you use the files app to look around in the Infuse app folder? Did you check the recently deleted folder in the files app even though you used Infuse to delete the files?

Ok, the files app, recently deleted folder just contains a few iCloud based files, no media. The Infuse folder just shows the few remaining items actually still synced.

Weirdly, the total used memory of the iPad shows 84GB, but the list of apps underneath shows Infuse using 301GB.


iOS doesn’t necessarily reclaim storage immediately. You can try a restart to see if it updates

I’ve just tried that, no change. I’ll keep monitoring it and report any changes. Thanks for your help.

OK, another day on. Finished my flight so deleted the remaining synced items. Nothing is now synced. Infuses memory usage is still 301GB. I really think this may now be a bug.

See screenshot (also, in the Files app, there is nothing in “recently deleted”).

Same issue for me. I’ve synced a quite big movie (78GB) to infuse, watched it and deleted the movie afterwards.
I’ve no files in the infuse folder nor in the “recently deleted” folder but infuse seems to still allocate 78GB of storage.

What I’ve noticed: In the “On My iPad” section of the files app, the infuse folder is listed with “1 item”, but opening that folder shows nothing. Is infuse keeping a “hidden” copy for some reason?

Why is this still not resolved?

This thread has had no posts for almost a year. There’s a more current thread that has shown a solution here.

Also there are some more refinements planned for 7.5.5

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.