Infuse not opening on Apple TV

I have Infuse on Apple TV, latest version - subscription up to date, testing on the Apple ID the subscription relates to.

This morning I tried to open infuse and it would not open, the App Icon just jumped and nothing happened. I tried rebooting the Apple TV with no success. All other apps work fine.

Tried deleting and reinstalling and restarting Apple TV. Same thing. When I download the new version of the app and click on “open” it kicks me to the front Page of Apple TV, but won’t open Infuse.

What gives? Is this just a bad build? How do I fix this?

thanks

It sounds like the tvOS may be causing problems. What version of tvOS is your apple TV running?

Corectamundo! Thanks.

So did you get it fixed? If not what version of tvOS are you running?

Yes. Fixed. Was stuck on 14.5 even though I have automatic updates on.

1 Like

I have the same problem but I am on the latest version. Any help?

What have you tried so far to fix it?

Restart the ATV?

Delete the Infuse app (delete, not just offload) and re-download it?

What version numbers of Infuse and tvOS?