Infuse not grabbing posters from Plex

Both Infuse app on my Apple TV and on my iPhone have broken posters for a COUPLE things. For example my Last Airbender Season 1 is grabbing poster from the main Last Airbender show poster. But is correctly grabbing season 2 and 3 poster just fine. For movies, Dark Knight Rises isn’t showing a poster AT ALL.

Are these posters visible within the Plex web app?

Can you try using the Refresh option in Infuse on these particular titles? Doing this should force Infuse to fetch the latest artwork from Plex.

Also, we’re looking into a specific issue which can appear while browsing via Plex folders. Are you browsing via folders or through Infuse’s library? Do you see a difference with either option?

They are visible under the Plex web app. I have tried refreshing folders in Infuse on both Apple TV and iOS. I’ve even tried deleting metadata and force refreshing again. I’ve turned off the file management and that hasn’t fixed it either :confused:

We have fixed a related issue for the upcoming 6.4 release, which could very well help in this particular case as well.

With any luck, we hope to have 6.4 available next week. :slight_smile: