Infuse not fetching cover art from Plex server

Hello, I am currently using the infuse app instead of the Plex app and Everything worked fine until today. I added 2 new movies to my library but the don’t show any kind of cover art. Description, rating etc is working but not the cover art.

Inside the Plex app and in the Browser everything is working fine. Juste the infuse app don’t Like these new movies.

All old movies added weeks ago working fine.
Embedded Meta and fetching meta is turned on.

Weird stuff: for a few minutes the app showed one of the two cover arts but it disappeared for no reason.

Maybe someone can help.

Thank you in advance.

I don’t know if it’s the cause of your problem but you probably want to turn off the “Embedded Metadata” option. Also if you provide the names of the movie files that are causing you problems may help figure out what’s going on.

Doesn’t help to turn off Embedded Metadata :confused: The Movies are Top Gun and Edge of Tomorrow, also written like this. But other written like this are working fine. In this case: Top Gun.mkv and so on

Unless you specifically have files that have embedded metadata that you want to use I’d leave the Embedded Metadata off. As to the file names, you should also consider making sure that Movies have the year immediately after the name just as on TV Shows it’s best to have S01E01 immediately after the show name.

You will probably have to do an “Edit Metadata” and re select the correct choice after you do any file name changes so Infuse will look for new info.

After renaming and editing the metadata in Plex, one of them showed the picture again, but the standard one. After picking a goof one from the Plex choices everything stopped working again.

Update: Top Gun is now fully working for no reason. It just appeared after a few minutes with no change or any other actions made. The other one still not working.