Infuse not adding latest movie from Jellyfin

I am a new Infuse user. I’m using the Apple TV 4K (2021) with Infuse Pro 7.2.2 (just updated) as the client, and Jellyfin 10.7.7 server running on Ubuntu 20.04. When I add movies the Jellyfin server, the movies don’t automatically show up the Home Page of Infuse. I have tried do the Scan for Changes from the Settings > Libary but no changes. The only way I can get it show added movies is by going to Settings > Library , then uncheck the Movies which resets the Movie counter, re-check Movies again, and then it will update with the added movies. From the Home screen, if I go to the Jellyfin favorites icon, click on the icon, it will list all the movies on the Jellyfin server. Shouldn’t all my movies show up on the Home screen of Infuse? I’ve got infusesync plugin version installed on Jellyfin.

Can you try installing v7.3? This has many improvements for Jellyfin.

Just updated to 7.3 but same results.

Did you restart the server after you installed InfuseSync?

Yes, the jellyfin server has been restarted several times. I run this on a laptop and it doesn’t run 24 hours a day. Also, the infusesync plugin was automatically added when I installed the jellyfin app on Ubuntu. I didn’t manually install it.

One other comment, I don’t use Trakt It’s my understanding that Trakt is tracking what movies or TV shows were watched on other devices and it remembers where you are. I don’t need that feature.

If the server isn’t running 24/7 then there could be a delay before they are added to the Jellyfin library. This in turn would affect how fast they are added to Infuse.

Is the Infuse app being left open? If so, you might try closing it and then entering the app. A scan should be triggered automatically when the app is opened.

When I web into jellyfin, the recently added movies are there already. they just don’t appear in the Infuse home screen. Don’t understand about the delay you’re talking about because when one launches the Infuse appl it automatically scans for updates, and the movies should then be added. Maybe I’m missing something or don’t understand the Infuse home screen. When I launch the Jellyfin appl from the Home screen, the recently added movies are listed.

No, the Infuse app is not being left open.

I also checked in Apple TV settings and verified that Background Refreshes were allowed by Infuse. Apple TV is running latest code 15.2.

I have the exact same problem, did you find a solution?

Since the OP’s post is rather old, can you state what exactly you’re seeing as compared to what should be expected?

Include the device(s) you are using Infuse on, including both devices that work correctly and devices where Infuse doesn’t work correctly.

List the AppleOS versions for those devices, and the versions of Infuse you are currently using.

If you have both working and non-working installations of Infuse, see if there are any settings differences between them.

I don’t use Jellyfin, so can only offer this general suggestion that might give others the information they need to help you.