Infuse Mac App Loading Forever, often failing

I have been troubleshooting issues with Infuse for 4 weeks with customer support to no avail, so am reaching out to the community for help.

I’ve been a paying user of Infuse Pro for a few months now and it used to work splendidly for viewing content off RealDebrid on my MacBook Pro M1. I would either copy a streaming link off Stremio linked to my RD account, or stream directly from my RD connected via webDAV to Infuse.

However, since around 12 May, links randomly started load incredibly slowly, or not at all, coming up with the “Failed to open input stream in demuxing stream” error message. Whenever Infuse would try to load a link, it would completely throttle my internet even for browsing Google, but still not load the video.

sometimes I MIGHT get the video to start loading just a little bit after letting it buffer for 10mins or more… but this is rare, and also much much worse than it used to be… this used to be the smoothest and best video player on the Mac!! And when it manages to do this… it still seems to buffer incredibly slowly… much slower than it used to. I can’t even see the highlighted “buffered” amount of a film in the scrolling bar after letting it load for 10mins.

I’ve tried all sorts of methods to try isolate the culprit - e.g.:

  • trying a different source,
  • trying a different video player (works well in Stremio Web and debrid media manager… loading much much faster and flawlessly. Unfort these are worse video players than Infuse!),
  • following these steps (How to reset or fully uninstall Infuse on the Mac) outlined by James (including deleting the data at ~/Library/Containers/Infuse),
  • reinstalling app
  • trying different WiFis (changing to multiple different locations), cellular data, and ethernet. Download speeds around 100mbps.
  • factory reset of entire computer

… but I’m still having the issue. It seems like an Infuse Mac app issue unless I’m missing something.

What’s more, the app is having all sort of other strange problems, like:

  • infinitely loading whenever I try to send a diagnostics report to customer support through “email use”
  • getting stuck on “deleting items” when I enable file management and try to delete a file

To make things more difficult, I can’t for the life of me figure out how to do a full reset of my Infuse account. I’ve tried the aforementioned steps to reset Infuse, and also deleted the iCloud data following these steps: iCloud Sync – Firecore Support … but Infuse still manages to remember all my previous activity (and presumably store data) from previous uses, even after a full factory reset of my laptop.

I should note that Infuse seems to still work seamlessly on my iPhone.

Someone please help! I’ve been tearing my hair out for a month trying to get to the bottom of this!

Is this off the same WiFi router at home or using cellular?

Just as a test have you tried using an Ethernet cable instead of WiFi on the Mac?