Infuse library resets by itself after sleep

Hi, a week ago i’ve updated to the tvos 11 and updated infuse to the 5.5.4.

However after the update, i have this problem that after apple tv wake up from sleep. The infuse library resets by itself. The problem seems random at times as sometimes the library intact sometimes its just gone.

Also the fav icons that ive changed previously reverts back to infuse original and the library data needs to be scanned all over again from beginning.

Any helps?

If you can drop us a report from the Apple TV the next time this happens we can look further into this.

Ok… next time will send you report when the problem occured…

Just did a reinstall of infuse app and will see if the problem persist…


I have the same problem since a while, too, and - sorry for the harsh words - I am really pissed off!! :angry:

In the past this happened randomly after a month or two, but since two weeks it happens about two or three times a week, a few days ago even twice within 24 hours!!! What the heck is going on? Any solutions, since it seems, that I am not the only one with this problem.

I have tried giving my ATV and NAS (WD MyCloud) static IPs. I deleted the App from my iPhone since it might is a problem with the sync via iCloud, but nothing changed! My last try today was switching off iCloud-Sync, but I can’t imagine that this should be the solution.

Also it takes about 3 hours to rebuild the library (2000+ Episodes and 500+ Movies), so that makes this bug even a larger pain in the ass! shok

Again, sorry for the hard language, but I needed to get rid of it! :wink:

@Nasstaucher72 Have you sent in a report as james requested of the original poster?

Also note that the original poster has done a reinstall of Infuse and not returned to this thread since so maybe that was what it took. Not sure but a possibility.

Just a personal observation, sometimes “getting rid” of hard language in a forum only makes it hard for some to respond with help.

Yes, report is already send. (ticket #97593)

Reinstalling is of course an option but it is the last one for me. Maybe the thread-starter can report if reinstalling had worked? :slight_smile:


Sorry for not getting back, but indeed reinstalling the app solved the issue for me.

Dont know what the problem was for causing this tho…

Looks like the answer is yes. Hope it works out as well for you!

Thanks for getting back to us on this! Much appreciated.

Weird the problem just happened again…

Already sent an email to support

Thanks. Took a quick look at your report, and this does seem to be related to tvOS’s auto-purge.

Specifically, your disk was at 19.6GB of 32GB used (though it was likely more full than that due to space reserved for the tvOS software and system apps). After the Library disappeared, you had only 219MB of 32GB used.

Sadly, we have little control over if and when tvOS decides to deleted cached info. However, Infuse will work to automatically repopulate everything the next time it is opened.

Just wondering if the high disk usage possibly caused by the daily download of the aerial screen saver?

As for apps dont have anything big installed, even netflix blocked by my country…

Today, it happened to me :frowning:
All gone

Hmm, that’s a good question, and yes I suppose it is possible.

Wouldn’t it be possible to use the information stored in iCloud in case this keeps happening?