Infuse is duplicating my library

On the library settings page on the left side there’s a message that tells what current action is going on like Fetching, Syncing, etc. (in your above pic it shows "Fetching metadata for AlisonNAS (29 of 18313) ) Have you started Infuse and gone right to that page and then monitor that message until it’s done the fetching ( this could take a while) and done the iCloud sync until it shows "Last Updated… " message for a minute or two?

The reason for the wait after the "Last Updated… " message is that the iCloud sync often will happen a few times after the fetch with a brief period between syncs that show the Last Updated message.

Another question, your library page shows some 5K+ TV show episodes but on your NAS you only show a “Movies” folder. Do you have your TV shows in that “Movies” folder too?

What all is inside that “Movies” directory on the NAS?

All my Movies and TV Shows are inside the Movies share folder. I had only recently cleared the metadata and began scanning again. It has taken around 2 hours to fully fetch all the data. But yes I have allowed it to fully complete

Can you try browsing through the share via the Settings > Shares > Share name menu to see what content is listed there?

You can also see the actual filename for a particular title by opening the details page and scrolling to the bottom (this will also be listed when using the Edit option on a particular title). Seeing the actual filename may shed some light on what is going on here.

1 Like

I have gone through all media on the system through the share setting, all the files are either mkv mp4 or avi. I have also had a thorough check through my database on my NAS and removed any files or folders that were not movies or tv shows. There was only 2 small files. No changes helped.

I have taken a proper look at my tv series and it has duplicated every episode. Again up to 4 copies. I thought it had not because I was only looking at the main folder, I didn’t actually notice the episode names. So this is happening to the entire collection on my NAS.

I am currently doing a backup of my NAS, once they finishes, I thought I might connect my external HDD and add that as a share again and see if the issue persists. If it doesn’t, we would have narrowed down to where it’s occurring. I suspecting something to do with the NAS, but I am unsure. I will let you know the outcome. Please let me know if any other ideas or troubleshooting. Thanks.

I have only seen this once before with Infuse and it was due to the DLNA protocol being used for the share. But you’ve indicated the share is SMB so the QNAP file indexing from DLNA service should not impact you.

I took these photos of my NAS settings. I’m not sure if there is anything in these settings that can be impacting. I am very tech savvy, but some of these settings I don’t fully understand yet, so I thought just best to send the photos for your viewing. Thanks. !




I’ll be watching this thread — I’ve had this exact same problem since I started using Infuse a couple years ago. Apple TV 4K connected to a Synology NAS over SMB. Have tried uninstalling Infuse and removing and re-adding the share in the Infuse settings multiple times but nothing has worked.

Does it make any difference to connect via NFS instead of SMB?

I have reconnected my backup HDD that has the entire copy of all the movies and series that is on my NAS. So far it appears to be working fine, it has correctly found the right amount of movies and episodes. In the photo I’ll share, you’ll see only around 6500 total. In the earlier pictures, it shows over 18000, which is definitely incorrect. I am guessing that the issue of duplicates is causing the incorrect count. But as to the cause, I am at a loss. I have also submitted a ticket to infuse support and to QNAP support, I am hoping we can find the resolution with everyone helping with even just the smallest of ideas.

I’m leaning toward it being an issue with “snapshots” on the QNAP. There’s a post in another thread regarding duplicate files and they solved the issue by addressing the snapshot files on their NAS.

I’m no NAS guru but it sounds feasible that these snapshot files may be what Infuse is seeing and indexing.

I do not know for sure but these files may be hidden so you may have to dig a bit. I tried to browse through the users manual for your NAS but it’s a ton of info that would make more sense to someone who can see the screens referenced. :wink:

1 Like

I was suspecting that snapshot could also be a likely cause. I have done a couple of snapshots. I can delete these completely and turn snapshots off as I do t really require them since I’m using a solid backup system.

I have been able to rule out that it is my movies and that it is not the infuse app. After letting it scan my external HDD, it did not duplicate any files. Shortly after my lunch, I’ll remove the snapshots completely and see how it helps.

Just a suggestion, you may want to first turn off snapshots and THEN delete or move the snapshot files. It seems that once deleted they will be recreated pretty quickly so best to turn off first? :wink:

Good luck!

There we are. I deleted the snapshot folder in the movies database. I removed all saved metadata and readded my share, it has found the correct amount of movies. It is not doing the scanning, I will wait until it has finished the scanning and then have a look at it, before I celebrate.

We have solved the issue. It was the snapshots file. Infuse is still fetching some artwork, but there are no more duplicates. Thank you to everyone who helped solve this and suggested all the ideas and troubleshooting. Now we have a strong cause behind this, hopefully others will see this post and help them too.

I do have 1 little question. One of my television series is Star Trek The Original Series, but I am having difficulty getting the metadata for one episode. It is called The Cage. I have tried renaming it a few times, but I can’t seem to get it right. I’ve tried placing it in Season 1 folder, also alone in the main folder and also outside with the movies, but search does not find any Star Trek The Cage

2 Likes