Infuse incorrectly classifies interlaced video, hides deinterlace option

I am playing an mpeg2-encoded video on an Apple TV 4K with Infuse. The video is interlaced, but I do not see the “deinterlace” checkbox option in the swipe-down menu while the video is playing. I am seeking a way to have Infuse deinterlace these videos. I’ve noticed this option is available for some videos and not others, so I assume Infuse is doing some sort of auto-detection of interlaced videos and hiding the option otherwise.

Questions:

  1. How does Infuse detect interlaced content? (this might allow me modify my files so they are correctly recognized as interlaced)
  2. If the above fails, is there a way to force-enable deinterlacing? (as-is, the option checkbox is hidden, preventing this)

Thanks

We’ve seen a few cases where interlaced videos are actually (incorrectly) encoded into a progressive video stream, thus appearing as progressive videos without a deinterlacing option in Infuse.

If you’re able to send in a sample we can take a deeper look into this particular video.

I have uploaded a sample clip from an affected file, which is a slice from a Stargate SG-1 episode copied from the DVD with MakeMKV. Interlacing is most obvious when switching between cameras, but also appears in the man’s swinging hair around the 1.581 second mark.

Can you provide any insight into how Infuse detects interlaced content? Does it rely on video tags or an auto-detection algorithm?

Thanks for the sample.

This is similar to another sample we have here, which is also not properly tagged as interlaced. We’ll take a look and see if there’s something we can do to improve support for these.

Attached is a screenshot from MediaInfo showing the tags which are usually included in interlaced videos.