Infuse freezes while playing a large video file on Ipad Pro 11

So I had a couple of video files of size around 9 Gb each and of MKV format and 4k resolution.
Infuse plays the video fine till the middle and then starts buffering indefinitely. I can not go forward or backward using the slider too as the app momentarily hangs. After some time the video restarts from the beginning.
I was wondering if there is a way to fix the issue.

Are you playing them from a network location or locally from the iPad?

Locally on Ipad. I had transferred the video from a USB drive by directly plugging it into the Ipad and then tried to play the video with Infuse. My other suspicion is that Ipad is messing up that transfer since the file size is too large. And thus a corrupt file is being stored or something. Dunnno.

It sounds like a corrupt file. Submit a report from within infuse and the developers will take a look at it.

I’d say before you even send in a diagnostic I’d see if VLC can play it through.

Also, can you stream it on the wifi connection past the place you have issues on the downloaded copy?

Is this happening with other files, or just this one?

If it’s just this one file, sending in a sample may help us track down what is going on.

It happened with multiple files. I think it is an issue with transferring the video from USB drive to Ipad. The large files are getting corrupted!? I don’t know.

Next, I will try to transfer files through Itunes and see if the problem persists.

Also, will it be possible ever to play files directly on the USB drive via Infuse without having to bring the file into Ipad’s memory? This would be a life saver.

You may give the 6.1.6 update, which was just released today a try to see if this is still happening.

We’re looking into direct USB streaming for an upcoming version.

From my (limited) tests of direct steaming on iOS 13, exFAT doesn’t seem to work for files larger than 4gb. That’s not with my thrown together app, that’s with the actual files app.

The same exact file plays fine with an hfs formatted drive.

I’ve submitted feedback in the app on the beta back in June, but had no response. Would be interested to know whether it works with infuse, and if it doesn’t, if you have better luck getting a response from Apple about it :stuck_out_tongue:

Come to think of it, if I can’t even read large files on an exFAT formatted drive via the API, I have a strong feeling this might also be corrupting the file if it were copied to the device itself. Just a theory though.

A maximum file size of 4GB is inherent in exFAT.

You’re thinking of FAT32.

FAT32: Drive size must be under 8TB and supports files up to 4GB - 2 Bytes.

exFAT: Supports drives up to 128PB and files up to 16EB. Really what exFAT supports is not super meaningful at this point in time due to what we have available to store files on.

For more detailed information:

Please try the 6.1.7 update of Infuse and iOS 13.1, and let us know if this is still an issue.

I’m having a similar issue with MKV files as well. My original topic that I attempted to post is still in review. It seems that if I copy MKV files (x265) in using the Files app I have weird scrolling to the end behavior in the timeline. If I use Infuse to browse to a network share with the same exact file and either download it or stream it in the file will play to the end. I’m running 6.1.7 with iOS 13.1. I’ve tried copying it from an SD card and from an external SSD to rule out a drive issue.

What is weird is that I’m able to copy in an m4v file (also x265) from the Files app and I don’t have any issues like this in Infuse.