Infuse DV lagging on M1 Pro

I’m playing a 4k DV mkv file on my M1 Pro Macbook Pro 16" on the latest OS and latest infuse version and its having trouble opening as in it takes about a minute to open and then after it does the whole player is slow to pause, seek go full screen… (rainbow loading…) The video lags every a few seconds where it like stutters and the video and audio go out of sync for a few seconds and then they stutter back to sync and this repeats every few seconds.
I transformed the mkv into mp4 using Subler and Infuse still struggles, however QuickTime plays it just fine.
Please fix this problem :frowning: its making for a very bad experience. Totally unwatchable

4k HDR mkv files play just fine.

Here’s the video I’m trying to play

ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main 10@L5@Main
HDR format                               : Dolby Vision, Version 1.0, dvhe.05.06, BL+RPU
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 1 h 9 min
Bit rate                                 : 19.5 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 24.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Bits/(Pixel*Frame)                       : 0.098
Stream size                              : 9.45 GiB (97%)
Default                                  : Yes
Forced                                   : No
Color range                              : Full

ID                                       : 2
Format                                   : E-AC-3 JOC
Format/Info                              : Enhanced AC-3 with Joint Object Coding
Commercial name                          : Dolby Digital Plus with Dolby Atmos
Codec ID                                 : A_EAC3
Duration                                 : 1 h 9 min
Bit rate mode                            : Constant
Bit rate                                 : 576 kb/s
Channel(s)                               : 6 channels
Channel layout                           : L R C LFE Ls Rs
Sampling rate                            : 48.0 kHz
Frame rate                               : 31.250 FPS (1536 SPF)
Compression mode                         : Lossy
Stream size                              : 286 MiB (3%)
Language                                 : English
Service kind                             : Complete Main
Default                                  : Yes
Forced                                   : No
Complexity index                         : 16
Number of dynamic objects                : 15
Bed channel count                        : 1 channel
Bed channel configuration                : LFE

There are a number of improvements/fixes for Profile 5 Dolby Vision coming in the 7.4.6 update. If you’re able to upload a sample file you are seeing issues with, we can take a deeper look.

Hey just updated to that version of the app, and the problem is still there, The UI is a bit more responsive than before though but still not great.

Profile 8 DV is working fine just like always, even though skipping further into the video takes time to load and the mouse pointer turns into the spinning rainbow every few seconds but its playing normally; However, profile 5 isn’t watchable at all. I uploaded a file to the dropbox link above if you wanna check it out.

@james sorry if I’m been impatient, but don’t know if my issue has reached you since I haven’t heard back from you. I’m wondering if there’s still something being done about this problem or is it solved but somehow not working for me?

Can you try installing macOS 13 to see if this has any effect? This does have some playback related fixes on M1 devices, so it’s possible this may help.

If the issue persists, sending in one of the problematic videos (using the link above) would allow us to try and replicate the issue here.

Hi - I keep going through this memory loop: try to watch dolby vision files with infuse, remember why I stopped using infuse due to the stutter that occurs every ~15 seconds, stop using infuse for a few months, and then go through the same cycle again because I forgot about the bug. It’s been like this for awhile! I purchased infuse specifically to watch dolby vision content. I have not used the application in months.

Sorry you’re still having problems.

What OS version number on the M1?

What Version number of Infuse?

What DV profile are you having problems with?

Could you provide a report from mediainfo for one of the files that is causing you problems?

Did you submit a copy of the video as requested above?