Infuse doesn’t work on Apple TV, but works in other Apple TV and iPad

I tried reaching out to Firecore for help with this issue (four times), but I’ve been entirely ignored. The problem started with the last update of version 6, but it persists with version 7. Infuse, for some reason, will not communicate with my media server, but only from this one device. I know the settings are correct. I even uninstalled the server. After several days of not working, I was able to reconnect to the server, and it worked fine for a day and then stopped working again. Since nobody who works for the company has been willing to reply to my repeated inquiries for assistance over the course of several weeks now, I was hoping somebody in the Firecore community could give me some insight as to why I can’t connect to my server only on one of my two Apple TV’s, and how I might fix it. Thanks.

How are you connecting to it (smb/nfs/plex/emby/etc)? Can you give a screenshot of infuse share settings on your devices (working and not)? Wi-Fi or ethernet? What is your media server device? Anything else detailing your setup. Did you post a diagnostic code?