Infuse doesn’t connect to my Windows SMB shares anymore

Hi,

Since Infuse 5.6.9 or 5.6.10, infuse doesn’t connect to my Windows 10 smb shares anymore. Though infuse displays the shares, it fails to connect to any of them. Instead it displays an error. Since I didn’t change the configuration of my Windows pc and vlc on my Apple 4K tv has no problems to connect to the smb shares, the problem must be with infuse.

This is particularly annoying because older versions of infuse did always connect. I’m currently on infuse 5.6.11 which I suppose is the latest version for Apple 4K tv.

Any suggestions are appreciated.

Thanks.

Have you tried the new SMB options in settings? If not, try them all but “Legacy” should put you back to the level before you had issues.

Thank you. That solved the problem!

I checked the smb settings. They were set to „auto“. That didn’t work. Setting it to „smb3“ or „smb2“ didn’t work either. What eventually worked was „legacy“. So what does that mean?

I believe that the Firecore folks did a pretty major re-write of the SMB code to comply with some of the newer standards and while it helped a lot of folks it hindered others so they made it an option to revert to what the original code was (Legacy) for those who couldn’t take advantage of the new code.

It was either that or voodoo. :wink:

Thank you.

Honestly, I’m a little bit disappointed about the result of the re-write of the smb code. That is because I was hoping for an improved smb connectivity. I run a standard Windows 10 pc as server, nothing special about it. So let’s hope that the guys continue their work on the smb code.

Do you by any chance know a nfs server software for Windows?

Not sure why you’re disappointed, the changes were to help folks that were having major issues with SMB and it did fix many problems. You were one of those that were working before the update and then benefited from the re inclusion of the “Legacy” code.

As to the Windows nfs server, I haven’t a clue. I owned my last windows machine when windows 3.1 was new. Went Mac and haven’t looked back. :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.