Infuse does not wake up my sleeping iMac, ref : Wake on Lan

Hi,

Really like Infuse, but …

Infuse on my iPad Air (latest version) does not wake my iMac in sleeping state (LAN connection, El Capitan 10.11.6)

When I use the Wake function in the Fing App on my iPad the iMac wakes up immediately.

I’ve read severals posts here re. Infuse refusing to wake a Mac, but never saw a solution.

My conclusion is that there seems to be a problem with the Wake on Lan function of Infuse.

Or can anyone confirm that it is working in his environment?

Kind regards.

What year iMac and how is it connected to the LAN?

Do you have an Apple TV or an Airport device?

Hi,

Thanks for your response.

My iMac is from half-2007, and is connected to my router with an Udp network cable. It’s no AirPort, but a TPLink.

I do have an Atv3, but with or without this connected to my network makes no difference.

Just heard from a friend that his 2017 iMac wakes up nicely from his Atv4 and from his iPad.

I can tell you with 100% certainty that the 2012 imac will not wake on lan over wireless but will over ethernet. You can run both ethernet and wireless at the same time as long as you send the wake on demand over the ethernet you’re good but you still need either an Apple TV or an Air Port family device to act as the Bonjour Sleep Proxy to do the wake ups.

I can also tell you as your friend did, the 2017 iMac CAN be woke over wifi or ethernet. Both work as advertised… Not sure what Apple has changed or when but I’ve run tests till I’m blue in the face and with the 2017 it just works.

I don’t think the issue lies with Infuse, I think it’s more in the iMacs wheelhouse.

Here’s a good article on the wake on lan settings for Apple.

Thanks for your reply, really appreciated!

I already had read the Apple article on “sleep proxy". Also found some informative technical background here:
http://stuartcheshire.org/sleepproxy/

My iMac does not seem to have a problem with a “standard” WakeOnLan, considering the fact that the Fing App wakes the iMac up every time. So when the iMac gets a WOL packet it is recognised and the iMac wakes up. There is no “Bonjour sleep proxy” in my network, but the iMac does not seem to need this. So far, so good.

But when I use Infuse when the iMac sleeps, it is NOT woken :frowning:
When I add an Atv3 to the network, that should function as a “Bonjour sleep proxy” Infuse still does not wake the iMac.

Some questions I have now:

  • Thats why I think that Infuse does have an issue, does’nt that make sense?
  • Could it be possible that Infuse is programmed to use “Bonjour sleep proxy” and does not send the old-fashioned “WOL magic packet”?

Sorry you’re having such a time. I went through a spell with Apple tech support a while back over this and after months of trial and error on my part I found a work around for my set up.

What Mac OS are you running on the iMac?
Have you checked in the energy saver control panel that it’s selected for wake for network access?
How are you telling when your iMac is truly asleep vs screen sleep?
Is your iMac using both Wifi and ethernet at the same time? This is possible and may hold a solution to your problem. Look at fing and see if there are two entries for your imac.

Sorry for so many questions but maybe we can figure it out.

Please find below the answers to your questions.

What Mac OS are you running on the iMac?

  • El Capitan 10.11.6

Have you checked in the energy saver control panel that it’s selected for wake for network access?

  • Yes, it is selected.

How are you telling when your iMac is truly asleep vs screen sleep?

  • During “screen sleep” you hear the fan, “true sleep” the fan is switched off and is totally silent. When woken you can hear the fan starting up again.

Is your iMac using both Wifi and ethernet at the same time? This is possible and may hold a solution to your problem. Look at fing and see if there are two entries for your imac.

  • Nope, ethernet only, wifi on iMac is switched Off. Fing has only 1 IP entry, for the ethernet connection.

Note : Friend of mine has the same iMac (2006 El Capitan) and this one wakes nicely when using Infuse on ATV4. Will ask him to test Infuse on iMac while ATV4 is switched off.

Thanks for your help.