Infuse created collections without image

H all,

After Infuse analyzed my library I ended end up with a bunch of collections which is great.

Two of them have been created without any image on the folder (Stanley Kubrick and Woody Allen).

How can I fix that ?

Platform : Apple TV

Thanks in advance.

What movies do you have showing in each?

Are you using something like Plex, Jellyfin, or Emby?

Here are the movies :

  • Stanley Kubrick Collection :
    Paths of Glory
    Dr. Strangelove
    Full Metal Jacket

  • Woody Allen collection :
    Annie Hall
    Manhattan
    Wonder Wheel
    A Rainy Day in New York

All these files are accessed directly on my NAS via SMB.

Could you provide a screen cap of what you’re seeing with no image for these?

You created these collections correct not Infuse?

What version of Infuse and what version tvOS?

Edit to add: Are these by chance Playlists and not collections?

Sorry for the poor quality of the screenshots but I don"t have any apple device other than the apple tv :slight_smile:

All my collections have been created automatically by Infuse, for the moment I haven’t created any on my own.

I have attached three screenshots :

  • One showing that I’m in the collection menu
  • One showing the collections without any image
  • One showing the context menu on these collections (I can’t remove them). Sorry for the french.

Infuse : 7.7.4
Apple TV : tvOS 17.4



Infuse will use data from TMDB to create collections, and I am not able to locate either of those collections on TMDB.

Are you using a media server like Emby, Jellyfin, or Plex? If so, Infuse will pull the collection artwork from there, so I would check to ensure the collections have artwork present on your server.

All what you say makes perfectly sense :slight_smile:

I actually did the same research on TMDB, there is actually this link referenced by Google : https://www.themoviedb.org/collection/1279672-woody-allen-collection

But it leads to non existing page.

  • All the files referenced by these two collections come from the SMB sharing :

I share only one as I don’t want to flood the post with screenshots but trust me it is the same SMB origin for the other files.

  • I do have a Plex server defined in my infuse confuration but this server only exposes 17 movies and none of them are from Kubrick or Allen (98% from my library is feeded by SMB)

  • As I’m currently extensively comparing Plex and Infuse on Apple TV, I have another Plex server configured on my network (not known by Infuse) which targets the same SMB sharing as the one used by Infuse. I have checked the collections created by this Plex server : there is no collection related to Kubrick or Woody Allen…

The mystery grows…

In this specific case, it would be useful to have the option to remove these collections.

Hope it helps.

Do you by chance have the Kubrick movies in their own directory? Same for Allen?

If those collections were previously present on TMDB - but removed recently - there may be some stale data in the TMDB caches.

You may try waiting a few days and the use the ‘Refresh All Metadata’ option found in Infuse > Settings > Library to pull down the latest metadata info from TMDB.

There’s defiantly something odd. Searching for Stanley Kubrick on TMDB shows there is a single collection but when you highlight the collection it says there are none.

All my movies are under a single “Movies” directory, there are no other levels in the directory structure.

1 Like

A week later there are some changes, I still have the two collections but with two films inside now and still no image on the collection folder.

A week later the “Refresh all metadata” action finally fixed the suspicious collections. Solved !

1 Like