Infuse Crashing after 30s (AppleTV)

My Infuse has been crashing lately. I can’t figure out the cause, emailed Firecore with the diagnostic code but haven’t heard back for several days.

My guess is it’s something corrupt its scanning but I have no idea what. The app works fine on my phone and every video I’ve added in the last week works fine when I try to play it.

Anyone have tips to help me locate the cause. The app is basically useless for me last 3-4 days since I cannot use it for more than a minute before it crashes and returns to Home Screen.

Does it crash right after you start it without you trying to play a video?

Correct. If I start a video fast enough sometimes it will stay active but it will often crash during the first few seconds of a video.

It’s crashing when browsing or just sitting on the menus. No interaction required.

It is scanning that I can see. Which is why I assume it’s related. It’s also quite outdated compared to my phone but this is may just be because it crashes before completing a scan.

It sounds like something has corrupted the app itself. If it was me I’d just delete the app and reinstall it.

What version of Infuse and what tvOS are you running?

Hmm, if it was the app, wouldn’t I be unable to watch anything? A few times I was able to quickly start a video and it played fine.

As for versions, latest for both Infuse and tvOS, generally first thing I do when having an issue is check for updates. I also have the AppleTV HD, not 4K if it makes a difference.

If I do delete the app and add again, what will I lose? I use Trakt, and iCloud Sync. So I imagine the status of everything is fine. I’m mostly concerned about playlists and other settings I’ve setup over the years. Curious which things will probably be reset so I can make note of them to restore after.

I believe that as long as you have iCloud sync on and it’s working with your iphone (syncing playlists and watched status) that you’d not lose anything but time. It may take a bit for it to reload the artwork from the sources but all of the textual metadata and the pref files should be restored from iCloud along with any corrections you’ve made.

Thanks, I’ll give it a try.

Something definitely odd.

Deleted and installed it fresh. Start it up and it still quits own it’s own. Just sitting on the home screen for Infuse. Haven’t added any shares or restored infuse subscription. Only thing I did was agree to share data with Firecore.

I’ve obviously tried rebooting the AppleTV too. Any logic in wiping my AppleTV, or am I just making extra work for myself, lol.

One difference between before and now (clean install with no data) is it takes about 120s to quit vs ~30s before.

Try to submit a diagnostic report before it crashes. The developers might be able to see what is going on

I did the first time. I can do it again though. Maybe easier to resolve since it’s a clean install right now.

one other thought, will other apps that access the internet run without quitting?

Also I know you said you’re running the “latest” versions of Infuse and tvOS but could you provide the numbers also? Since things change so quickly sometimes it helps to have the actual version numbers. :wink:

Delete the app and reinstall. Once reinstall disconnect from the AppleTV and open the app. If it doesn’t crash then it might be corrupt iCloud data.

My internet connection has been dropping recently too, but no other apps have issues, aside from buffering or disconnecting if my connection dies completely. No apps randomly quitting.

In terms of software, I’m running tvOS 14.0.2 and Infuse 6.5.2.

I left my internet connection enabled and disabled iCloud Sync and it hasn’t crashed. Enabled it and it crashed within a minute or so. Certainly seems iCloud related, though odd that the iPhone app syncs perfectly fine. No crashing and no errors. All changes are updated too.

Assuming I need to wipe the iCloud Data, any tips on what I’m losing here? I’m guessing all my playlists? :confused: Any way to preserve it or export somehow so I can rebuild. Setup a lot of them over the last year.

I haven’t tried it but if you disable iCloud sync on your iPhone and then delete the data once you enable iCloud sync it should repopulate the the cloud with whatever is on the iPhone.

Sadly no fix for me, but your theory works. I was able to turn off iCloud Sync and delete the data without losing anything. Before enabling iCloud Sync on my phone I turned it on the AppleTV and it didn’t crash. However, once I enabled sync on my phone again the AppleTV started crashing again.

iCloud looking highly sus! However I’d rather not wipe all Infuse data and rebuild from scratch unless it’s a last resort. Will take quite a while to rebuild my playlists. Trakt has my watch status so I think playlists and any metadata corrections will be the only things truly lost. My worry is I will do all that and then discover that it was crashing because of an entirely separate reason.

We’ve had a chance to look into this, and it appears to be related to a rather massive number of playlist items which are being synced from iCloud.

Long-story short, Infuse currently stores playlist info in the Apple TV’s non-volatile memory (memory that isn’t wiped out when tvOS cleans up disk space). This space isn’t unlimited, but it’s been enough for all the scenarios we’ve seen up to this point. However, in this case the space isn’t large enough and is leading to a crash.

We are looking into possible ways to improve support for storing larger playlists like these.

For now, you can avoid the crash by disabling iCloud Sync, or removing a few playlists (via another device).

I had a feeling that might have been the case. Thanks for the update. I sent Feedback a little while ago about adding Smart Playlists (similar to Music/iTunes). May be useful to cut down on my excessive playlists. The general size would be the same, but maybe storage could be lower and the device itself would populate the playlist content.

1 Like

FYI, we have a fix for this coming in 6.5.3.

For now, if you want to leave iCloud Sync off on the Apple TV, you should be able to turn it back on after the release of 6.5.3.

Oh I definitely trashed everything and rebuilt it. :smiley: My OCD lacks patience. However, I’d be more than happy to push the limits to ensure the new update is working as expected. Thanks for the quick turn around!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.