Infuse crashes at start up

I had to download infuse 5 (pro) again in tvOS. Now it crashes at start up every time. I’ve tried restarting the Apple TV, reinstalling the app and so on. Doesn’t seem to help. Any suggestions?

I have no other versions of Infuse installed.

Edit 1: It seems to be an issue with the iCloud account. When iCloud account is activated on the Apple TV, Infuse crashes. When it’s not activated, and I reinstall the app, Infuse doesn’t crash. But I need iCloud sync, so please help…

Edit 2: In “desperation” i reset the Apple TV to factory settings. Same problem. I bought the other Infuse app (paid app). It crashes just like the other one. A waste of my money…Now what? Will I never be able to use Infuse again because of some iCloud and Infuse connection bug? My family and I have been addicted to Infuse. We have thousands of movies.This is a sad story :frowning:

Edit 3: On some occations when I try opening the app, I can se the right favorite folders are there, but then it shuts down again.

Edit 4: It seems the longer I wait before i try re-opening the app, the longer it takes before it shuts down.

Edit 5: Next thing I tried: delete all shares / favorite folders from iOS app. Then reinstall Infuse on Apple TV and log on to iCloud. Then add one favorite folder at the time in iOS app. This seems to work. Infuse on tvOS hasn’t crashed so far. The huge downside is that I have to do all the metadata work again from scratch. However, at least I can use Infuse again, which after all is the most important thing.

What could have caused this? Can the crash be due to large amounts of metadata (1-2 GB)?

In the past we’ve seen a few cases of this occurring when Infuse has trouble scanning/indexing a corrupt file.

If you’re able to send in a report from one of your devices it may help us track down what’s going on in this case.

I’ve sent in a report from my iPhone. However, after re-installing everything from scratch, it seems to work as it should, so I’m not sure the report is of any value. If a corrupt file is causing this, I obviously want to get rid of it.

Please tell me if there’s anything more you need. Thanks in advance.

We’ll take a look. Thanks!

Hi.

I have also had this issue since the new 5.4 update arrived to Apple TV4. The problem seems to happen when Infuse is adding the metadata and for some reason fails/get stuck when fetching the data for some videofiles. I have removed and reinstalled Infuse about 10 times now since the update, because when the error occurs, you are thrown out of the app. If I try to enter the app it behaves differently every time, it can throw you out immediately or the app is open up to 10 seconds then throw you out. I have tried restarting the AppleTV4 and also removed the power for a while, but the issue is still there when trying to open the app once it has happened.
And my experience is that it don’t have something to do with the files themselves but rather that the metadata for the file is corrupted for some reason. The reason I concluded this is because the error occurs on different files each time when it occurs.
The first time it happened when I manually was adding metadata from the search feature when editing the metadata for a videofile. The last time it happened (yesterday) it happened when I added a new videofile to one of my folders on my NAS. And when entering Infuse it opened as usual and when I entered the folder “New Movies” and selected the movie (which had no metadata at the time), Infuse tried to add metadata (I know this because I just saw a glimpse of the movie thumbnail that Infuse added and then I was thrown out).

So I am pretty sure that the problem is related to the fetching of metadata for videofiles.

Is there some way I can help you in narrowing this down James? It’s starting to get really annoying to have to reinstall it 3-4 times a week…

PS! By the way, I am really happy that you fixed the subtitles in the last update. It’s now working and the subtitle is no longer taking up 25% of my screen height =). The only thing I think that is still an issue, is that the styling is horrible on subtitles that is built in the videofile. The edges is all pixelated.

James?

You may try installing 5.4.2 to see if that helps.

If that doesn’t help, sending in a report from one of your devices will help us track down what’s going on.

Hi James.
It didn’t help AND I can’t send any report from the ATV4, as the app crashes. When the error occurs and I try over and over again to enter the app, I can enter the app for about 0 seconds up to 3 seconds. But not enough time to send a report.

The app is stable as long as I don’t remove any movies from the folders on my NAS which is added to Infuse (this is my guess for the cause). The app have been stable since I updated. But I haven’t added or removed anything until today. I deleted a couple of movies on my NAS and added a couple of others. I then entered the app and the crashing occured immediately.
When I have opened the app one time, it is still running in the background which I can see by double clicking the home button twice. I have tried closing the app and even restarted the ATV4, but I am still thrown out of the app… I also have tried letting it run in the background for a while to see if the issue resolves by itself, but no luck.
So the only solution is to reinstall it again. Really frustrating. A wild guess is that it has something to do with metadata fetching, and that Infuse for some reason can’t handle when something is removed.

When I think of it, maybe the issue has something to do with replacing a video file with another video file with the same title, but not the same file name? I do this often because I want a movie with better quality. Can you see if you reproduce this?

Just add a video file and make sure metadata is fetched and then remove it from the source with Infuse closed. And then add the same movie but with another file name and try to start Infuse after this.

Just a thought, maybe you could add something like “.test.” in the replacement file name to see if it works for your specific set up. Like replacing “End.Of.The.World.2017.mkv” with “End.Of.The.World.2017.test.mkv” .

That would be the most accurate way to see if your specific problem occurs instead of someone else with subtle differences not experiencing the same outcomes as you.

Just a thought. Hope you can narrow it down!

It is not impossible that this may be the case.

Lately, I have:

  • replaced one version of a movie with a better one (deleted a lossy m4v file and replaced it with a lossless mkv file). For example “movie name.m4v” out, “movie name.mkv” in.
  • placed two versions of the same movie (such as a DVD version and a blu-ray version) in the same folder. For example “movie name (DVD).mkv” and “movie name (blu-ray).mkv”

Earlier I also have had two versions of the same movie connected to Infuse, but then they were in different folders.

Hi.
Thanks for your input. My suggestions of what may possible trigger this, is just suggestions.
The bottomline is that it is always occuring when I remove and add movies. And the problem started with the 5.4 version.

AND your replacement of files have a difference from mine, I replaced the files with files in the same format, replacing the mkv-file with another mkv-file.

Can it possible have something to do with the way I access the source folders (on my Synology NAS). I use NFS and Infuse only have read abilities on the shared folders.

Anyway, the issue started with version 5.4, so something must have changed that triggers the issue I encounter. Will see if I can trigger it again and see if I can pin point exactly what I did before it happens.

I just thought it may have something to do with two different files having the same metadata in the same folder, regardless of format. It’s only a suggestion from me too.

I have several folders where I have double copies of movies (e.x one theatrical version and one extended/directors cut and so on), so that doens’t seem to be a problem for Infuse at all. So it must be something else triggering the issue.

That shouldn’t cause an issue, and typically when we’ve seen issues like this (which has not been very often) it’s been related to Infuse having trouble scanning a specific file.

Is Infuse open while you are transferring/replacing files? I could imagine a scenario where Infuse is scanning and then files are changed mid-scan, or Infuse attempting to scan a file that has not yet been fully transferred.

When I think of it, I may have had the app running in background.
But I stumbled on another problem, that may be related to this. Infuse insist on refreshing a bunch of my movies and tv-shows. This occurs several times per day even if nothing have changed.

I don’t know how many times it have done that now. When I enter “Libraries” (spelling as I have my GUI in Swedish) I have a total of ~2200 items. ~770 movies, ~690 tv-show episodes and “other” ~740 items. Almost everytime I enter “Libraries” Infuse start to scan the source (my Synology NAS) and the about ~300 movies disappear from movies and about ~200 tv-episodes and they are moved to the “other” counter. And then Infuse starting to download metadata for all these movies and tv-episodes that it already have downloaded several times. So when it is done, which takes a long time, the numbers are the same as the initial counter again…

So maybe I have transfered movies or deleted movies at a time when it is refreshing the metadata? But the obvious question then is, why do Infuse insist on downloading metadata and thumbnails on videofiles it already have collected metadata for?

I also noticed yesterday that Infuse suddenly have downloaded several thumbnails for movies with Russian titles, altough the app is set to Swedish. And I can add, that those movies had the right thumbnails earlier yesterday, but I guess it has done a refresh again and downloaded the wrong thumbnails for some reason.

It could have happened that Infuse was open in the background. I’m not sure to be honest.

That the app crashes is in itself not a big problem, even if it is a bug. The problem is that when this happens, there is no way out of it except deleting all favorite folders and metadata and build up Infuse from scratch. Which of course is a whole lotta work for some collections.

All in all, good to hear that this is a rare issue. I still love Infuse?

Oh my, I am really tired of Infuse right now… 3 times this week I had to remove it from AppleTV4 and reinstall the app because of being thrown out of the app.
I haven’t removed anything in the source folders, just added videos. And the app have continued to re-fetching metadata and thumbnails that already is in place several times per day.
Why is Infuse fetching the same metadata/thumbnails over and over again?
I am pretty sure this is the issue, that causes the app crash. That I am accidentally happen to add a video when the meta refresh is occurring. This is my best guess right now, because I cannot find any other reasonable cause for this.

Starting to regret the payment of the Pro-version of this app, as it is useless right now.

Please send us a report from your device so we can look into your particular case. Thanks!

I would love to James, but how? Because when the crash occur, I can’t do anything with Infuse. If I could, I would have sent it several weeks ago…