Infuse can't play one movie

Hello,
using Infuse Pro 5 for a a months and had no problems. Today I wanted to play movie Batman Begins but I found a problem. Can’t play that movie. I see loading icon only and black screen. If I want to turn off Infuse Pro, it freezes (must wait about 5 minutes).

Tried to play movie on MacBook Pro, laptop Lenovo, iPhone, Samsung Galaxy S10+. No problems. I also tried to play the movie from USB in TV, works fine.

Any idea please?
Attaching mediainfo log.

Thank you.

mediainfo.txt (3.72 KB)

Couple of questions, first are you still running Infuse 5 Pro or have you updated to version 6? Second, when you say “turn off” infuse are you talking about clicking the menu button or are you talking about double clicking the home button and swiping up? Lastly, have you tried restarting your ATV?

Have infuse pro 5. Didn’t update to 6. Yes I’m talking about clicking on “menu button”. Of course, I restarted ATV, same result…

Is this affecting other videos, or just this one?

Have you tried playing this in Infuse 6? You can receive a free 30 day trial of Infuse Pro, so you would be able to test at no cost.